Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#21544 closed defect (fixed)

libsdl 1.2.14 checksum failed

Reported by: senz@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: SDL 1.2.14 checksum Cc: jan.hosang@…, nox@…, gale@…, ryandesign (Ryan Schmidt), jrminter@…, mas@…, domiman@…
Port: libsdl

Description

--->  Attempting to fetch SDL-1.2.14.tar.gz from http://www.libsdl.org/tmp/
--->  Verifying checksum(s) for libsdl
Error: Checksum (md5) mismatch for SDL-1.2.14.tar.gz
Error: Checksum (sha1) mismatch for SDL-1.2.14.tar.gz
Error: Checksum (rmd160) mismatch for SDL-1.2.14.tar.gz
Error: Target org.macports.checksum returned: Unable to verify file checksums

Change History (23)

comment:1 in reply to:  description Changed 11 years ago by jan.hosang@…

I can confirm this issue. More details:

--->  Checksumming SDL-1.2.14.tar.gz
Error: Checksum (md5) mismatch for SDL-1.2.14.tar.gz
Portfile checksum: SDL-1.2.14.tar.gz md5 6726575f6c6a799e24210e22ee751052
Distfile checksum: SDL-1.2.14.tar.gz md5 b916b29ece2c4f3618e51318003e4cc3
Error: Checksum (sha1) mismatch for SDL-1.2.14.tar.gz
Portfile checksum: SDL-1.2.14.tar.gz sha1 db9a714fe9c00163e2708111a64f065861e95464
Distfile checksum: SDL-1.2.14.tar.gz sha1 c15e75aafc6394f296050c8f87f87ef65c04ff2b
Error: Checksum (rmd160) mismatch for SDL-1.2.14.tar.gz
Portfile checksum: SDL-1.2.14.tar.gz rmd160 f5e2b01c48ce1087e97d8074674989437dc3a26c
Distfile checksum: SDL-1.2.14.tar.gz rmd160 402abd5842b43357d04bf74c0fa0e23daa772dca
The correct checksum line may be:
checksums           md5     b916b29ece2c4f3618e51318003e4cc3 \
                    sha1    c15e75aafc6394f296050c8f87f87ef65c04ff2b \
                    rmd160  402abd5842b43357d04bf74c0fa0e23daa772dca
Error: Target org.macports.checksum returned: Unable to verify file checksums

comment:2 Changed 11 years ago by jan.hosang@…

Cc: jan.hosang@… added

Cc Me!

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… toby@… added
Owner: changed from macports-tickets@… to nox@…

comment:4 Changed 11 years ago by gale@…

Cc: gale@… added

Cc Me!

comment:5 Changed 11 years ago by ryandesign (Ryan Schmidt)

Toby, in r58082 you updated the port to 1.2.14 but also changed the download location from /release to /tmp. The homepage still mentions 1.2.13 as the latest version available. Are we sure 1.2.14 is ready to be used? Perhaps you can compare the currently-available SDL-1.2.14.tar.gz with the one you received yesterday and see what's different.

comment:6 Changed 11 years ago by tobypeterson

Cc: toby@… removed

I've since reformatted the machine I installed it on. Just commit a fix for it

comment:7 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: nox@… added; ryandesign@… removed
Owner: changed from nox@… to ryandesign@…
Status: newassigned

comment:8 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Fixed in r58114. Let me know if it happens again.

comment:9 Changed 11 years ago by software@…

The checksums have changed again. However, since I can not reopen the bug, I submitted a new one: #21569

comment:10 Changed 11 years ago by Veence (Vincent)

Resolution: fixed
Status: closedreopened

comment:11 in reply to:  5 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Replying to ryandesign@…:

The homepage still mentions 1.2.13 as the latest version available. Are we sure 1.2.14 is ready to be used?

The answer seems to be no. Fixed the latest checksum mismatch in r58178 by downgrading to 1.2.13. This reopens #20235.

comment:12 Changed 11 years ago by tobypeterson

Reverted r58178 in r58179. A completely broken libsdl does not do any good - upgrading daily is an inconvenience, but working is better than not working.

comment:13 Changed 11 years ago by js-macports@…

It's happening again:

Error: Checksum (md5) mismatch for SDL-1.2.14.tar.gz
Portfile checksum: SDL-1.2.14.tar.gz md5 18895c7865c971e7e6c00bdd97e697ca
Distfile checksum: SDL-1.2.14.tar.gz md5 1c4203d2dffbde5a333fa6e9620e38b8
Error: Checksum (sha1) mismatch for SDL-1.2.14.tar.gz
Portfile checksum: SDL-1.2.14.tar.gz sha1 cb2239860b41821150f4208435aee08987bec0cd
Distfile checksum: SDL-1.2.14.tar.gz sha1 8e083e9dcaff346f5bec143fc5f1808488dc99f5
Error: Checksum (rmd160) mismatch for SDL-1.2.14.tar.gz
Portfile checksum: SDL-1.2.14.tar.gz rmd160 e4faaf504b2c05d9ce6aec79ed55ab1ef7cb8e95
Distfile checksum: SDL-1.2.14.tar.gz rmd160 2e3bca08655a27c542445aa9275b08da7f9ce306
The correct checksum line may be:
checksums           md5     1c4203d2dffbde5a333fa6e9620e38b8 \
                    sha1    8e083e9dcaff346f5bec143fc5f1808488dc99f5 \
                    rmd160  2e3bca08655a27c542445aa9275b08da7f9ce306

Is it safe to just update the checksums? Wouldn't it make more sense to just backport the fix from .14 to .13?

comment:14 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

comment:15 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from ryandesign@… to toby@…
Status: reopenednew

comment:16 Changed 11 years ago by blb@…

Cc: jrminter@… added

Cc reporter of dup #21655.

comment:17 Changed 11 years ago by blb@…

Resolution: fixed
Status: newclosed

Updated in r58357.

comment:18 Changed 11 years ago by mas@…

Cc: mas@… added

Cc Me!

comment:19 Changed 11 years ago by domiman@…

can the SDL SVN be bumped again? I tried to compile the SVN of SDL 1.2 myself but didn't succeed. Not urgent but it would be nice if it could be bumped every couple of days, since we ARE using the SVN version...

comment:20 Changed 11 years ago by domiman@…

Cc: domiman@… added

Cc Me!

comment:21 Changed 11 years ago by tobypeterson

We're not using the svn version, and if the port doesn't build that's a separate issue - it apparently builds fine for most people. Please don't comment in closed tickets, it's basically just extra noise.

comment:22 Changed 11 years ago by domiman@…

Sorry for commenting in a closed ticket, it's just that this fits the issue more than a new ticket and it has been discussed here. And true, this is not the SVN but a snapshot of the SVN, so my request would be to use a more up to date snapshot. I have no problem with this port but with building either the newest snapshot of the SVN or the newest SVN, take your pick, both fail...

comment:23 Changed 11 years ago by tobypeterson

Oh, the newer snapshots fail to build? All the more reason to stick with the current one.

Note: See TracTickets for help on using tickets.