Opened 11 years ago

Closed 11 years ago

#21584 closed defect (fixed)

octave-3.2.2 -- build failure -- likely arpack issue

Reported by: rkcrockett@… Owned by: alakazam@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: arpack gcc43 Cc: stechert@…, joshua@…, pmcarlton@…, bpabbott@…, td@…, halfpricewine@…
Port: octave

Description (last modified by blb@…)

Building octave +gcc43 from a fresh macports install, 10.6.1, I get:

--->  Building octave
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_math_octave/work/octave-3.2.2" && /usr/bin/make -j2 all " returned error 2
Command output: /opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o convhulln.oct pic/convhulln.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran -lqhull
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o daspk.oct pic/daspk.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o dasrt.oct pic/dasrt.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o dassl.oct pic/dassl.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o det.oct pic/det.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o dispatch.oct pic/dispatch.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o dlmread.oct pic/dlmread.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o dmperm.oct pic/dmperm.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o eig.oct pic/eig.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o eigs.oct pic/eigs.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran -larpack
/opt/local/bin/g++-mp-4.3 -bundle -bundle_loader ../src/octave -L/opt/local/lib -o fft.oct pic/fft.o -L../libcruft -lcruft -L../liboctave -loctave -L. -loctinterp -lcholmod -lmetis -lumfpack -lamd -lcamd -lcolamd -lccolamd -lcxsparse  -lfftw3 -lfftw3f -lqrupdate -larpack -lreadline  -lncurses -framework Accelerate -lhdf5 -lz -lm  -L/opt/local/lib -lfreetype -lz -Wl,-framework -Wl,OpenGL -L/opt/local/lib -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4 -L/opt/local/lib/gcc43/gcc/x86_64-apple-darwin10/4.3.4/../../.. -lhdf5 -lz -lm -lfreetype -lgfortranbegin -lgfortran
Undefined symbols:
  "_znaupd_", referenced from:
      EigsComplexNonSymmetricFunc(ComplexColumnVector (*)(ComplexColumnVector const&, int&), int, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::complex<double>, int, int, int&, ComplexMatrix&, ComplexColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrix<ComplexMatrix>(ComplexMatrix const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, int, int, int&, ComplexMatrix&, ComplexColumnVector&, ComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrix<SparseComplexMatrix>(SparseComplexMatrix const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, int, int, int&, ComplexMatrix&, ComplexColumnVector&, SparseComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrixShift<SparseComplexMatrix>(SparseComplexMatrix const&, std::complex<double>, int, int, int&, ComplexMatrix&, ComplexColumnVector&, SparseComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrixShift<ComplexMatrix>(ComplexMatrix const&, std::complex<double>, int, int, int&, ComplexMatrix&, ComplexColumnVector&, ComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
  "_zneupd_", referenced from:
      EigsComplexNonSymmetricFunc(ComplexColumnVector (*)(ComplexColumnVector const&, int&), int, std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::complex<double>, int, int, int&, ComplexMatrix&, ComplexColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrix<ComplexMatrix>(ComplexMatrix const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, int, int, int&, ComplexMatrix&, ComplexColumnVector&, ComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrix<SparseComplexMatrix>(SparseComplexMatrix const&, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, int, int, int&, ComplexMatrix&, ComplexColumnVector&, SparseComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrixShift<SparseComplexMatrix>(SparseComplexMatrix const&, std::complex<double>, int, int, int&, ComplexMatrix&, ComplexColumnVector&, SparseComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
      int EigsComplexNonSymmetricMatrixShift<ComplexMatrix>(ComplexMatrix const&, std::complex<double>, int, int, int&, ComplexMatrix&, ComplexColumnVector&, ComplexMatrix const&, ColumnVector&, ComplexColumnVector&, std::basic_ostream<char, std::char_traits<char> >&, double, int, bool, int, int) in eigs.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [eigs.oct] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [src] Error 2
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Change History (13)

comment:1 Changed 11 years ago by blb@…

Cc: stechert@… added
Description: modified (diff)
Keywords: octave removed
Owner: changed from macports-tickets@… to alakazam@…
Port: octave added

comment:2 Changed 11 years ago by joshua@…

Cc: joshua@… added

Cc Me!

comment:3 Changed 11 years ago by pmcarlton@…

Cc: pmcarlton@… added

Cc Me!

comment:4 Changed 11 years ago by bpabbott@…

Cc: bpabbott@… added

Cc Me!

comment:5 Changed 11 years ago by td@…

Cc: td@… added

Cc Me!

comment:6 Changed 11 years ago by halfpricewine@…

Cc: halfpricewine@… added

Cc Me!

comment:7 Changed 11 years ago by holin@…

See #21989 for a possible solution.

comment:8 in reply to:  7 Changed 11 years ago by pmcarlton@…

Replying to holin@…:

See #21989 for a possible solution.

I changed the octave 3.2.2 Portfile to read

use_parallel_build no

and it still didn't work, failed at eigs.oct complaining about zneupd and znaupd.

I am running a fresh install of MacPorts in 10.6.1.

I tried inserting that line into the arpack Portfile and the octave-arpack Portfile too, and it still didn't work.

comment:9 Changed 11 years ago by halfpricewine@…

You shouldn't have to insert it because the arpack portfile was updated to have it? I cleaned everything and retried and it worked after the arpack fix.

comment:10 in reply to:  9 Changed 11 years ago by pmcarlton@…

Replying to halfpricewine@…:

You shouldn't have to insert it because the arpack portfile was updated to have it? I cleaned everything and retried and it worked after the arpack fix.

Ah, my mistake was not cleaning, I think. Mine works perfectly well now after the fix.

comment:11 Changed 11 years ago by rkcrockett@…

@holin: Thanks, #21989 fixes this for me, as well.

@alakazam: I think you can mark this ticket fixed.

comment:12 Changed 11 years ago by bpabbott@…

Works for me as well

comment:13 Changed 11 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed

Confirmed.

Note: See TracTickets for help on using tickets.