Opened 8 years ago

Closed 7 years ago

#21706 closed defect (fixed)

i386-elf-gcc @4.3.2 (cross, devel) - configure error - build failure

Reported by: Richard.Beare@… Owned by: stepan@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc: pguyot@…, stuart.adamson@…, iamstuffed@…, bjorn@…, matt.massicotte@…, bhadder@…, wcmiii@…, mf2k (Frank Schima), k.pranas@…
Port: i386-elf-gcc

Description

OSX 10.5.8 Xcode 3.14

sudo port upgrade outdated

sudo port clean i386-elf-gcc
Password:
--->  Cleaning i386-elf-gcc 

sudo port install i386-elf-gcc
--->  Computing dependencies for i386-elf-gcc
--->  Fetching i386-elf-gcc
--->  Verifying checksum(s) for i386-elf-gcc
--->  Extracting i386-elf-gcc
--->  Applying patches to i386-elf-gcc
--->  Configuring i386-elf-gcc
--->  Building i386-elf-gcc
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build" && /usr/bin/make -j1 all AR_FOR_TARGET=i386-elf-ar AS_FOR_TARGET=i386-elf-as LD_FOR_TARGET=i386-elf-ld NM_FOR_TARGET=i386-elf-nm RANLIB_FOR_TARGET=i386-elf-ranlib " returned error 2
Command output: echo timestamp > gpl.pod
perl /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-4.3.2/gcc/../contrib/texi2pod.pl /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-4.3.2/gcc/doc/include/gpl_v3.texi > gpl.pod
echo timestamp > doc/gpl.7
(pod2man --center="GNU" --release="gcc-4.3.2" --section=7 gpl.pod > doc/gpl.7.T$$ && \
		mv -f doc/gpl.7.T$$ doc/gpl.7) || \
		(rm -f doc/gpl.7.T$$ && exit 1)
Checking multilib configuration for libgcc...
mkdir i386-elf
mkdir i386-elf/libgcc
Configuring in i386-elf/libgcc
configure: creating cache ./config.cache
checking for --enable-version-specific-runtime-libs... no
checking for a BSD-compatible install... /usr/bin/install -c
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking build system type... i386-apple-darwin9.8.0
checking host system type... i386-pc-elf
checking for i386-elf-ar... i386-elf-ar
checking for i386-elf-lipo... i386-elf-lipo
checking for i386-elf-nm... /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build/./gcc/nm
checking for i386-elf-ranlib... i386-elf-ranlib
checking for i386-elf-strip... /opt/local/i386-elf/bin/strip
checking whether ln -s works... yes
checking for i386-elf-gcc... /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build/./gcc/xgcc -B/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build/./gcc/ -nostdinc -B/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build/i386-elf/newlib/ -isystem /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build/i386-elf/newlib/targ-include -isystem /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-4.3.2/newlib/libc/include -B/opt/local/i386-elf/bin/ -B/opt/local/i386-elf/lib/ -isystem /opt/local/i386-elf/include -isystem /opt/local/i386-elf/sys-include
checking for suffix of object files... configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.
make[1]: *** [configure-target-libgcc] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Attachments (1)

config.log (16.4 KB) - added by Richard.Beare@… 8 years ago.

Download all attachments as: .zip

Change History (25)

Changed 8 years ago by Richard.Beare@…

comment:1 Changed 8 years ago by mf2k (Frank Schima)

  • Cc pguyot@… added
  • Owner changed from macports-tickets@… to stepan@…
  • Port i386-elf-gcc added

comment:2 Changed 8 years ago by blb@…

  • Cc stuart.adamson@… added

Cc reporter of dup #21757.

comment:3 Changed 8 years ago by iamstuffed@…

  • Cc iamstuffed@… added

Cc Me!

comment:4 follow-up: Changed 8 years ago by mwolfram@…

Workaround is to run ./libgcc/configure with --host=i386-apple-darwin9.8.0, this solves the issue when the configure script tries to execute the target compiler on the host system.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 8 years ago by mwolfram@…

Replying to mwolfram@…:

Workaround is to run ./libgcc/configure with --host=i386-apple-darwin9.8.0, this solves the issue when the configure script tries to execute the target compiler on the host system.

Had some problems with other errors, so this is nonsense. Doing step by step myself I could see that a make install-gcc solved it.

comment:6 in reply to: ↑ 5 Changed 8 years ago by Richard.Beare@…

Sorry to ask such a basic question - I'm new to macports internals. Where should I be running manual builds? I attempted

cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build/ sudo make install-gcc

sudo port install i386-elf-gcc

and got the same errors. I guess this isn't the right way...

Replying to mwolfram@…:

Replying to mwolfram@…:

Workaround is to run ./libgcc/configure with --host=i386-apple-darwin9.8.0, this solves the issue when the configure script tries to execute the target compiler on the host system.

Had some problems with other errors, so this is nonsense. Doing step by step myself I could see that a make install-gcc solved it.

comment:7 Changed 8 years ago by Richard.Beare@…

Hi, Could you expand on the list of steps and where to run them? I've tried various combinations of

sudo make install-gcc AR_FOR_TARGET=i386-elf-ar AS_FOR_TARGET=i386-elf-as LD_FOR_TARGET=i386-elf}-ld NM_FOR_TARGET=i386-elf-nm RANLIB_FOR_TARGET=i386-elf-ranlib

but always get errors.

Thanks

comment:8 Changed 8 years ago by bjorn@…

  • Cc bjorn@… added

Cc Me!

comment:9 Changed 8 years ago by bjorn@…

This problem can be addressed by updating the Portfile as described in r59653 (which closes #21194).

After applying both patches I got the following error:

--->  Activating i386-elf-gcc @4.3.2_0
Error: Unable to execute port: Image error:
/opt/local/lib/x86_64/libiberty.a is being used by the active i386-elf-binutils port.  Please deactivate this port first, or use 'port -f activate i386-elf-gcc' to force the activation.

I decided to force the activation, without really knowing the consequences. That seemed to work.

(This same comment was posted to #21682, which describes a similar problem)

comment:10 Changed 8 years ago by matt.massicotte@…

  • Cc matt.massicotte@… added

Cc Me!

comment:11 Changed 8 years ago by matt.massicotte@…

  • Cc matt.massicotte@… removed

Cc Me!

comment:12 Changed 8 years ago by matt.massicotte@…

  • Cc matt.massicotte@… added

Cc Me!

comment:13 Changed 8 years ago by bhadder@…

  • Cc bhadder@… added

Cc Me!

comment:14 Changed 8 years ago by wcmiii@…

  • Cc wcmiii@… added

Cc Me!

comment:15 follow-up: Changed 8 years ago by stepan@…

Ok, who can commit this?

comment:16 in reply to: ↑ 15 Changed 8 years ago by mf2k (Frank Schima)

Replying to stepan@…:

Ok, who can commit this?

Commit what? Please supply a patch. I looked at r59653 and those changes are already there.

comment:17 Changed 8 years ago by mf2k (Frank Schima)

  • Cc macsforever2000@… added

Cc Me!

comment:18 Changed 8 years ago by stepan@…

Ah, ok. Then I can't help. I don't have any 10.5.x systems anymore, sorry.

comment:19 Changed 8 years ago by mf2k (Frank Schima)

I'm on Snow Leopard. Although my error is in the build phase, it is the same basic problem.

comment:20 Changed 8 years ago by k.pranas@…

  • Cc k.pranas@… added

Cc Me!

comment:21 Changed 8 years ago by k.pranas@…

  • Cc k.pranas@… removed

Cc Me!

comment:22 Changed 8 years ago by k.pranas@…

  • Cc k.pranas@… added

Cc Me!

comment:23 Changed 8 years ago by k.pranas@…

Same problem on SL 10.6.3 using current MacPorts

comment:24 Changed 7 years ago by jmroot (Joshua Root)

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this. The use of -arch was removed by r63114, and the libiberty.a conflict, which is a completely separate issue which should have gone in a separate ticket, was fixed by r72086.

Note: See TracTickets for help on using tickets.