Opened 11 years ago

Closed 10 years ago

#23047 closed defect (fixed)

CocoaDialog is not 64 bits friendly

Reported by: tsupplis@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: haspatch maintainer Cc:
Port: CocoaDialog

Description

CocoaDialog fails with BAD_ACCESS when using bubble when started in 64 bits mode. To reproduce: .../CocoaDialog bubble --text test --title test

The problem is mainly due to float vs CGFloat usage.

Patch files submitted as well as Portfile update

Attachments (1)

CocoaDialog.tar.gz (3.3 KB) - added by tsupplis@… 11 years ago.
patch files and Portfile update

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by tsupplis@…

Attachment: CocoaDialog.tar.gz added

patch files and Portfile update

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Keywords: haspatch maintainer added; aqua 64-bits removed

comment:2 Changed 10 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: newclosed

Committed in r70898.

Note: See TracTickets for help on using tickets.