Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#23483 closed defect (fixed)

awesome dependency cairo-xcb

Reported by: jamesabernard@… Owned by: milosh@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: macports.org@…, ryandesign (Ryan Schmidt)
Port: awesome cairo

Description (last modified by mf2k (Frank Schima))

Awesome WM not compiling because of missing dependency of cairo-xcb. As xcb is now supported in cairo, is this dependency now defective? I can't find way round, don't know how to change comile flags or whatever. Help would be appreciated.

-- checking for modules 'glib-2.0;cairo;x11;pango>=1.19.3;pangocairo>=1.19.3;xcb-randr;xcb-xtest;xcb-xinerama;xcb-event>=0.3.6;xcb-aux>=0.3.0;xcb-atom>=0.3.0;xcb-keysyms>=0.3.4;xcb-icccm>=0.3.3;xcb-image>=0.3.0;xcb-property>=0.3.0;cairo-xcb;libstartup-notification-1.0>=0.10;xproto>=7.0.15;imlib2;libxdg-basedir>=1.0.0'
--   package 'cairo-xcb' not found
CMake Error at /opt/local/share/cmake-2.8/Modules/FindPkgConfig.cmake:259 (message):
  A required package was not found

Attachments (1)

cairo-xcb.diff (3.7 KB) - added by jmroot (Joshua Root) 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 in reply to:  description Changed 11 years ago by jamesabernard@…

Replying to jamesabernard@…:

Awesome WM not compiling because of missing dependency of cairo-xcb. As xcb is now supported in cairo, is this dependency now defective? I can't find way round, don't know how to change comile flags or whatever. Help would be appreciated.

-- checking for modules 'glib-2.0;cairo;x11;pango>=1.19.3;pangocairo>=1.19.3;xcb-randr;xcb-xtest;xcb-xinerama;xcb-event>=0.3.6;xcb-aux>=0.3.0;xcb-atom>=0.3.0;xcb-keysyms>=0.3.4;xcb-icccm>=0.3.3;xcb-image>=0.3.0;xcb-property>=0.3.0;cairo-xcb;libstartup-notification-1.0>=0.10;xproto>=7.0.15;imlib2;libxdg-basedir>=1.0.0' -- package 'cairo-xcb' not found CMake Error at /opt/local/share/cmake-2.8/Modules/FindPkgConfig.cmake:259 (message):

A required package was not found

I have figured this out:
install cairo +x11_xcb and then awesome will compile
Shouldn't cairo +x11_xcb be a dependency? as the standard cairo doesn't have xcb support?

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Cc: jamesabernard@… removed
Description: modified (diff)
Keywords: awesome cairo-xcb removed
Owner: changed from macports-tickets@… to milosh@…
Port: 3.3.4_0 removed

comment:3 Changed 11 years ago by macports.org@…

When preparing the patch to update awesome to version 3.3.3 I tried to include the variant dependency +x11_xcb and this is not yet supported by macports.
See FAQ and #126.
Apparently, adding a default variant x11_xcb with an empty variant block did not work either (I found this workaround somewhere on a mailing list. sorry, forgot the url).
The only solution I know is to create a new port cairo-xcb and change the dependency in awesome to cairo-xcb.

comment:4 Changed 11 years ago by macports.org@…

Cc: macports.org@… added

Cc Me!

comment:5 Changed 11 years ago by lance@…

Can also confirm this issue on 2 machines.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Cc: ryandesign@… added
Port: cairo added

XCB should probably be used all the time in cairo (unless X11 is disabled of course) now that that's done in libX11.

Changed 10 years ago by jmroot (Joshua Root)

Attachment: cairo-xcb.diff added

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Patch for cairo attached.

comment:8 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

comment:9 Changed 10 years ago by ryandesign (Ryan Schmidt)

Merged r78840 and r78842 to cairo-devel in r78848.

Note: See TracTickets for help on using tickets.