Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#23705 closed defect (fixed)

portindex not being updated

Reported by: singingwolfboy@… Owned by: wsiegrist@…
Priority: Normal Milestone:
Component: server/hosting Version:
Keywords: Cc:
Port:

Description

For some reason, "port outdated" doesn't seem to be noticing that my version of freetype is out of date. I was poking around at the mftrace port, and I noticed that when I ran "sudo port install mftrace", the first thing it started downloading was the source code for freetype, which isn't in mftrace's dependency tree.

Clearly, this is a very minor bug, since "port install" picked up the fact that freetype was out of date, but "port outdated" and "port list outdated" did not. I've attached a log of the sort of conflicting output I'm seeing. I have no idea if this is reproducible, but on the off chance that people are interested in poking at this, I'm going to try to leave my Macports install untouched (i.e. not update freetype) so that we can dig into this problem.

Attachments (2)

outdated.log (1.6 KB) - added by singingwolfboy@… 13 years ago.
outdated.log.2.txt (1.5 KB) - added by singingwolfboy@… 13 years ago.

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by singingwolfboy@…

Attachment: outdated.log added

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Are you sure the index had been updated?

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Component: baseserver/hosting
Owner: changed from macports-tickets@… to wsiegrist@…
Priority: LowNormal
Summary: "port outdated" doesn't pick up outdated freetypeportindex not being updated
Version: 1.8.2

It had not, last update was 30 hours ago.

Changed 13 years ago by singingwolfboy@…

Attachment: outdated.log.2.txt added

comment:3 Changed 13 years ago by singingwolfboy@…

I just ran a selfupdate and tried again -- same result. Log attached.

comment:4 Changed 13 years ago by jmroot (Joshua Root)

Yes, because the index is not being updated.

comment:5 Changed 13 years ago by wsiegrist@…

Resolution: fixed
Status: newclosed

Port index generation has been fixed.

comment:6 Changed 13 years ago by singingwolfboy@…

Yes, after the latest selfupdate, it finds freetype as outdated. Confirmed as fixed.

Note: See TracTickets for help on using tickets.