Opened 9 years ago

Closed 8 years ago

#23999 closed submission (fixed)

kdesvn: new port

Reported by: cjones051073 (Chris Jones) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: kdesvn

Description

Hi,

Here is a Portfile and a couple patch files for kdesvn (KDE4).

The patch files fix a couple issues in the current release (raised upstream) and a conflict resolution with kdesdk (that is not a bug but a packaging decision that has to be made).

cheers Chris

Attachments (4)

Portfile (1.1 KB) - added by cjones051073 (Chris Jones) 9 years ago.
app-install-and-icon-fix.patch (866 bytes) - added by cjones051073 (Chris Jones) 9 years ago.
no-kdesdk-conflict.patch (365 bytes) - added by cjones051073 (Chris Jones) 9 years ago.
ignore-apr0-and-apr-util0.patch (565 bytes) - added by ryandesign (Ryan Schmidt) 9 years ago.

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by cjones051073 (Chris Jones)

Attachment: Portfile added

Changed 9 years ago by cjones051073 (Chris Jones)

Changed 9 years ago by cjones051073 (Chris Jones)

Attachment: no-kdesdk-conflict.patch added

comment:1 Changed 9 years ago by cjones051073 (Chris Jones)

Ok, so what happens next ? Is there something I need to do to get this accepted or rejected ?

cheers Chris

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Port: kdesvn added
Status: newassigned
Summary: Portfile and associate patch files for kdesvnkdesvn: new port

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

It doesn't build for me:

cd /opt/local/var/macports/build/_Users_rschmidt_macports_dports_kde_kdesvn/work/build/src/svnqt && /opt/local/bin/cmake -E cmake_link_script CMakeFiles/svnqt.dir/link.txt --verbose=1
/usr/bin/g++-4.2  -O2 -arch x86_64  -fno-common -Woverloaded-virtual -fvisibility=hidden -fvisibility-inlines-hidden -fexceptions -O2 -DNDEBUG -DQT_NO_DEBUG -arch x86_64 -isysroot /Developer/SDKs/MacOSX10.6.sdk -mmacosx-version-min=10.6 -dynamiclib -headerpad_max_install_names    -single_module -multiply_defined suppress -L/opt/local/lib -compatibility_version 6.0.0 -current_version 6.0.2 -o ../../lib/libsvnqt.6.0.2.dylib -install_name /opt/local/lib/libsvnqt.6.dylib CMakeFiles/svnqt.dir/apr.o CMakeFiles/svnqt.dir/client_annotate.o CMakeFiles/svnqt.dir/client_cat.o CMakeFiles/svnqt.dir/client.o CMakeFiles/svnqt.dir/client_diff.o CMakeFiles/svnqt.dir/client_ls.o CMakeFiles/svnqt.dir/client_modify.o CMakeFiles/svnqt.dir/client_property.o CMakeFiles/svnqt.dir/client_status.o CMakeFiles/svnqt.dir/context.o CMakeFiles/svnqt.dir/datetime.o CMakeFiles/svnqt.dir/dirent.o CMakeFiles/svnqt.dir/entry.o CMakeFiles/svnqt.dir/exception.o CMakeFiles/svnqt.dir/log_entry.o CMakeFiles/svnqt.dir/path.o CMakeFiles/svnqt.dir/pool.o CMakeFiles/svnqt.dir/revision.o CMakeFiles/svnqt.dir/status.o CMakeFiles/svnqt.dir/targets.o CMakeFiles/svnqt.dir/url.o CMakeFiles/svnqt.dir/version_check.o CMakeFiles/svnqt.dir/wc.o CMakeFiles/svnqt.dir/lock_entry.o CMakeFiles/svnqt.dir/client_lock.o CMakeFiles/svnqt.dir/info_entry.o CMakeFiles/svnqt.dir/client_impl.o CMakeFiles/svnqt.dir/contextdata.o CMakeFiles/svnqt.dir/commititem.o CMakeFiles/svnqt.dir/repository.o CMakeFiles/svnqt.dir/repositorydata.o CMakeFiles/svnqt.dir/repositorylistener.o CMakeFiles/svnqt.dir/repoparameter.o CMakeFiles/svnqt.dir/svnstream.o CMakeFiles/svnqt.dir/diff_data.o CMakeFiles/svnqt.dir/svnfilestream.o CMakeFiles/svnqt.dir/stringarray.o CMakeFiles/svnqt.dir/diffoptions.o CMakeFiles/svnqt.dir/conflictdescription.o CMakeFiles/svnqt.dir/conflictresult.o CMakeFiles/svnqt.dir/client_merge.o CMakeFiles/svnqt.dir/cache/LogCache.o CMakeFiles/svnqt.dir/cache/ReposLog.o CMakeFiles/svnqt.dir/cache/DatabaseException.o CMakeFiles/svnqt.dir/cache/ReposConfig.o CMakeFiles/svnqt.dir/client_parameter.o CMakeFiles/svnqt.dir/client_commit_parameter.o CMakeFiles/svnqt.dir/client_annotate_parameter.o -F/opt/local/libexec/qt4-mac/lib -L/opt/local/lib -framework QtCore -lpthread -L/opt/local/lib -lapr-0 -lresolv  -lpthread -L/opt/local/lib -laprutil-0 -ldb-4.4 -lexpat -liconv /opt/local/lib/libsvn_client-1.dylib /opt/local/lib/libsvn_diff-1.dylib /opt/local/lib/libsvn_fs-1.dylib /opt/local/lib/libsvn_ra-1.dylib /opt/local/lib/libsvn_repos-1.dylib /opt/local/lib/libsvn_subr-1.dylib /opt/local/lib/libsvn_wc-1.dylib -framework QtSql 
ld: library not found for -ldb-4.4

db44 is installed, and libdb-4.4.dylib does exist, but in /opt/local/lib/db44; I don't see "-L/opt/local/lib/db44" in the command above which is why it can't find the library.

subversion and apr-util switched from db44 to db46 some time ago; if BerkeleyDB is needed for kdesvn, it would be good for it to use db46 as well.

kdesvn and its dependencies don't even declare a dependency on db44, so it shouldn't be used (or a dependency should be declared).

comment:4 Changed 9 years ago by cjones051073 (Chris Jones)

Hi,

Hmmm, I didn't see any of this myself when putting it together. I'm not with my mac at the moment, but will take a look after Easter.

Chris

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Part of the problem is I had apr-util0 installed (which depends on db44). Seems kdesvn only looks for apr-1-config and apu-1-config if it doesn't find apr-config and apu-config. apr0 and apr-util0 provide apr-config and apu-config, respectively, so kdesvn finds apr/apu version 0, which is not what we want, since our Subversion is built using apr/apu version 1. Using the attached patch for src/svnqt/cmakemodules/FindSubversion.cmake fixes this for me, and leads me to....

ld: library not found for -ldb-4.6

Is your subversion and apr-util perhaps installed with the +no_bdb variant? If so that might explain why you didn't see the problem.

Changed 9 years ago by ryandesign (Ryan Schmidt)

comment:6 in reply to:  5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

Is your subversion and apr-util perhaps installed with the +no_bdb variant? If so that might explain why you didn't see the problem.

It does finally build for me if I rebuild apr-util with the +no_bdb variant first. But the app crashes on launch.

comment:7 Changed 9 years ago by cjones051073 (Chris Jones)

OK, back at my Mac now ...

Turns out I don't have the MacPorts versions of subversion or apr-util (any version) installed, and under these conditions it works fine.

I'll next try with these installed and see what happens.

Chris

comment:8 Changed 9 years ago by cjones051073 (Chris Jones)

Question - I guess for consistency I should made kdesvn depend on subversion perhaps apr-util ?

Chris

comment:9 Changed 9 years ago by ryandesign (Ryan Schmidt)

I committed the port in r66181 with some changes, including adding my patch to ignore apr0 and adding the subversion dependency. We can go forward from here and apply additional changes as needed to get it to work.

comment:10 Changed 8 years ago by ryandesign (Ryan Schmidt)

Michael made some improvements in r74338.

comment:11 Changed 8 years ago by michaelld (Michael Dickens)

My changes fix the "ld: library not found for -ldb-4.6" issue mentioned above. Is ticket #27352 now a duplicate of this one maybe? Has kdesvn ever installed for anyone? The current is:

cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesvn/work/kdesvn-1.5.5/doc/nl && /opt/local/bin/meinproc4 --check --cache /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesvn/work/build/doc/nl/index.cache.bz2 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesvn/work/kdesvn-1.5.5/doc/nl/index.docbook
index.docbook:14: warning: failed to load external entity "dtd/kdex.dtd"
]>

which shouldn't even be being built since +docs variant isn't selected. I'll look into this issue later in the week unless someone else beats me to it ;0

comment:12 Changed 8 years ago by ryandesign (Ryan Schmidt)

Yes I was able to compile it before (after committing r66181), but it crashed when I tried to run it.

comment:13 Changed 8 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

Closing as this submission has been committed.

Note: See TracTickets for help on using tickets.