Opened 10 years ago

Closed 10 years ago

#24137 closed defect (fixed)

doxygen +wizard fails build on Snow Leopard

Reported by: dreadrik@… Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: haspatch Cc:
Port: doxygen

Description

Linking of doxywizard fails due to missing i386 and ppc platforms in the qt4-mac libs.

This seems to be because of the fixed targets in addon/doxywizard/doxywixard.pro

My attached patch removes these, but it might screw up something on other platforms.

Attachments (1)

Portfile.patch (711 bytes) - added by dreadrik@… 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by dreadrik@…

Attachment: Portfile.patch added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Keywords: haspatch added; wizard removed
Owner: changed from macports-tickets@… to css@…

Please remember to cc the maintainer.

comment:2 Changed 10 years ago by jameskyle@…

I've confirmed this works with 10.6.x on my mac pro, if someone else confirms it doesn't screw up other platforms/arches I'll commit the change.

and thanks.

comment:3 Changed 10 years ago by jameskyle@…

oops, submitted too soon. scratch that.

comment:4 Changed 10 years ago by jameskyle@…

Resolution: fixed
Status: newclosed

I've modified the Portfile so it should build on all arches correctly and committed the changes.

comment:5 Changed 10 years ago by dreadrik@…

Resolution: fixed
Status: closedreopened

Broken again after 1.6.3 update.

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_doxygen/work/doxygen-1.6.3" && /usr/bin/make -j8 all " returned error 2
Command output:       InputStrList::updateString()       in inputstrlist.o
      InputStrList::delString()      in inputstrlist.o
      InputStrList::addString()      in inputstrlist.o
      configlex()    in config_lex.o
      configlex()    in config_lex.o
      configlex()    in config_lex.o
      configlex()    in config_lex.o
      configlex()    in config_lex.o
      configlex()    in config_lex.o
  "QRegExp::matchedLength() const", referenced from:
      substEnvVarsInString(QString&)      in config_lex.o
  "QLabel::~QLabel()", referenced from:
      InputBool::InputBool(QGridLayout*, int&, QString const&, bool, QString const&)in inputbool.o
      InputString::InputString(QGridLayout*, int&, QString const&, QString const&, InputString::StringMode, QString const&, QString const&)in inputstring.o
      InputInt::InputInt(QGridLayout*, int&, QString const&, int, int, int, QString const&)in inputint.o
      InputStrList::InputStrList(QGridLayout*, int&, QString const&, QStringList const&, InputStrList::ListMode, QString const&)in inputstrlist.o
      HelpLabel::~HelpLabel()in moc_helplabel.o
      HelpLabel::~HelpLabel()in moc_helplabel.o
  "QWidget::setWindowTitle(QString const&)", referenced from:
      MainWindow::updateTitle()       in doxywizard.o
  "QTextEdit::setFontFamily(QString const&)", referenced from:
      MainWindow::MainWindow()in doxywizard.o
ld: symbol(s) not found for architecture i386

comment:6 Changed 10 years ago by cssdev

Does it work if you install qt4-mac +universal?

comment:7 Changed 10 years ago by dreadrik@…

I doubt qt4-mac is the only dependency for the wizard, and I have no intention of installing universal variants for every dependency.

Until someone can verify that my patch works on i386/ppc targets it's easier for me to just apply it locally.

comment:8 Changed 10 years ago by cssdev

I think when I noticed r65829 I didn't look closely enough whether it was the patch from this ticket. Verifying a new build with this ticket's patch ...

comment:9 Changed 10 years ago by cssdev

I just committed r67836, and I successfully built and ran doxywizard on my system. There was an error with the path to qmake. Please let me know if the latest revision works for you, too.

comment:10 Changed 10 years ago by dreadrik@…

I just built and run doxywizard here with Portfile r67836, and it worked like a charm. However, I didn't actually verify the qmake fix, since I have symlinked qmake to qmake-mac on my system.

Thanks!

comment:11 Changed 10 years ago by cssdev

Resolution: fixed
Status: reopenedclosed

Marking this as closed, thanks for the feedback!

Note: See TracTickets for help on using tickets.