Opened 13 years ago

Closed 12 years ago

#24215 closed defect (duplicate)

caml-sqlite3 1.5.6 build fails

Reported by: jonathan.a.myers@… Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version: 1.8.99
Keywords: Cc: stechert@…
Port: caml-sqlite3

Description

caml-sqlite build fails; build log contains:

info:build ocamlmklib -o sqlite3 -oc sqlite3_stubs sqlite3.cmo sqlite3_stubs.o -L. -L/opt/local/lib -arch x86_64 -lsqlite3  -L/opt/local/lib -linkall
:info:build Unknown option -arch
:info:build Don't know what to do with x86_64
:info:build Usage: ocamlmklib [options] <.cmo|.cma|.cmx|.cmxa|.ml|.mli|.o|.a|.obj|.lib|.dll files>
...
:info:build make: *** [sqlite3.cma] Error 4
...

Attachments (1)

main.log (13.0 KB) - added by jonathan.a.myers@… 13 years ago.
Build log showing failure

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by jonathan.a.myers@…

Attachment: main.log added

Build log showing failure

comment:1 Changed 13 years ago by mf2k (Frank Schima)

Cc: stechert@… added
Owner: changed from macports-tickets@… to landonf@…
Port: caml-sqlite3 added
Summary: caml-sqlite 1.5.6 build failscaml-sqlite3 1.5.6 build fails

comment:2 Changed 13 years ago by warrensomebody@…

I'm hitting this too on mac 10.5.8:

 :info:build ocamlmklib -o sqlite3 -oc sqlite3_stubs sqlite3.cmo sqlite3_stubs.o -L. -L/opt/local/lib -arch i386 -lsqlite3  -L/opt/local/lib -linkall
 :info:build Unknown option -arch
 :info:build Don't know what to do with i386

Any work-arounds would be most appreciated.

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #23040.

Note: See TracTickets for help on using tickets.