Opened 9 years ago

Closed 8 years ago

#24397 closed defect (fixed)

smpeg doesn't build universal on SL 10.6.3

Reported by: ih-mon@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: raimue (Rainer Müller)
Port: smpeg

Description

Hey, I have to upgrade my wxwidgets and it needs a universal build of libsdl-mixer which needs a universal build of smpeg which fails. see this:

EBUG: Requested variant macosx is not provided by port expat.
DEBUG: Executing variant universal provides universal
DEBUG: No need to upgrade! expat 2.0.1_0 >= expat 2.0.1_0
DEBUG: No need to upgrade! gettext 0.17_4 >= gettext 0.17_4
DEBUG: No need to upgrade! p5-locale-gettext 1.05_2 >= p5-locale-gettext 1.05_2
DEBUG: No need to upgrade! help2man 1.37.1_1 >= help2man 1.37.1_1
DEBUG: No need to upgrade! autoconf 2.65_1 >= autoconf 2.65_1
DEBUG: No need to upgrade! automake 1.11.1_0 >= automake 1.11.1_0
DEBUG: No need to upgrade! libtool 2.2.6b_1 >= libtool 2.2.6b_1
DEBUG: variant override ... upgrading!
--->  Computing dependencies for smpeg
DEBUG: Searching for dependency: libsdl
DEBUG: Found Dependency: receipt exists for libsdl
DEBUG: Searching for dependency: libtool
DEBUG: Found Dependency: receipt exists for libtool
DEBUG: Executing org.macports.main (smpeg)
DEBUG: Skipping completed org.macports.fetch (smpeg)
DEBUG: Skipping completed org.macports.checksum (smpeg)
DEBUG: Skipping completed org.macports.extract (smpeg)
DEBUG: Skipping completed org.macports.patch (smpeg)
DEBUG: Skipping completed org.macports.configure (smpeg)
--->  Building smpeg
DEBUG: Executing org.macports.build (smpeg)
DEBUG: port disallows a parallel build
DEBUG: Environment: MACOSX_DEPLOYMENT_TARGET='10.6'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_smpeg/work/smpeg-0.4.4" && /usr/bin/make all'
Making all in audio
/bin/sh ../libtool --mode=compile /usr/bin/g++-4.2 -DPACKAGE=\"smpeg\" -DVERSION=\"0.4.4\"  -I. -I.    -I/opt/local/include  -O2 -arch x86_64 -arch i386 -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -DTHREADED_AUDIO -DNDEBUG -I.. -DNOCONTROLS -I.. -I../audio -I../video -fno-exceptions -fno-rtti -c MPEGaudio.cpp
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[1]: *** [MPEGaudio.lo] Error 1
make: *** [all-recursive] Error 1
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_smpeg/work/smpeg-0.4.4" && /usr/bin/make all " returned error 2
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_smpeg/work/smpeg-0.4.4" && /usr/bin/make all " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for smpeg): org.macports.destroot org.macports.build
DEBUG: couldn't read file "/opt/local/share/macports/Tcl/darwintrace1.0/pkgIndex.tcl": no such file or directory
    while executing
"source [file join $dir pkgIndex.tcl]"
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

and that:

[macports]$ sudo port upgrade --enforce-variants libsdl_mixer +universal
--->  Computing dependencies for smpeg
--->  Building smpeg
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_smpeg/work/smpeg-0.4.4" && /usr/bin/make all " returned error 2
Command output: Making all in audio
/bin/sh ../libtool --mode=compile /usr/bin/g++-4.2 -DPACKAGE=\"smpeg\" -DVERSION=\"0.4.4\"  -I. -I.    -I/opt/local/include  -O2 -arch x86_64 -arch i386 -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -DTHREADED_AUDIO -DNDEBUG -I.. -DNOCONTROLS -I.. -I../audio -I../video -fno-exceptions -fno-rtti -c MPEGaudio.cpp
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[1]: *** [MPEGaudio.lo] Error 1
make: *** [all-recursive] Error 1

Error: Unable to upgrade port: 1
Before reporting a bug, first run the command again with the -d flag to get complete output.

Attachments (4)

patch-src-Makefile.diff (308 bytes) - added by jeffrey.m.engel+macports@… 9 years ago.
patch-audio-Makefile.diff (320 bytes) - added by jeffrey.m.engel+macports@… 9 years ago.
patch-video-Makefile.diff (320 bytes) - added by jeffrey.m.engel+macports@… 9 years ago.
smpeg-autotools-fixed.diff (31.9 KB) - added by raimue (Rainer Müller) 8 years ago.
Large diff containing changes for Portfile and files

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Cc: mww@… removed
Owner: changed from macports-tickets@… to mww@…
Summary: smpeg doesn't build universe on SL 10.6.3smpeg doesn't build universal on SL 10.6.3

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Can't reproduce this, universal i386/x86_64 smpeg installs fine.

comment:3 Changed 9 years ago by ajb78@…

I just encountered the same error - also on SL 10.6.3 and XCode 3.2.2

comment:4 Changed 9 years ago by lkraider (Paul Eipper)

Same issue here, but I am building (-)universal, so the description can include the problem also for non universal builds.

Adding the option --tag=CXX for the LTCXXCOMPILE defines on the Makefiles fixes the issue.

comment:5 Changed 9 years ago by lkraider (Paul Eipper)

Correction: the Makefiles require more changes, there are more usages of LIBTOOL that require setting the tag for the compilation to work.

My system: SL 10.6.4 and XCode 3.2.2

comment:6 in reply to:  5 Changed 9 years ago by jeffrey.m.engel+macports@…

I was able to patch the 3 Makefiles in smpeg to get this port to compile. I am not building universal. (SL 10.6.4, XC 3.2.2)

I changed the line:

LIBTOOL = $(SHELL) $(top_builddir)/libtool

to:

LIBTOOL = $(SHELL) $(top_builddir)/libtool --tag=CXX

My patches are attached.

Changed 9 years ago by jeffrey.m.engel+macports@…

Attachment: patch-src-Makefile.diff added

Changed 9 years ago by jeffrey.m.engel+macports@…

Attachment: patch-audio-Makefile.diff added

Changed 9 years ago by jeffrey.m.engel+macports@…

Attachment: patch-video-Makefile.diff added

Changed 8 years ago by raimue (Rainer Müller)

Attachment: smpeg-autotools-fixed.diff added

Large diff containing changes for Portfile and files

comment:7 Changed 8 years ago by raimue (Rainer Müller)

Cc: raimue@… added

Using autoreconf the latest libtool version will be used to compile smpeg which should hopefully fix any compile issues related to libtool. I ported some of the patches from Gentoo.

Sorry that I didn't attach smaller files, but it was easier for me this way.

comment:8 Changed 8 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Maintainer timeout, committed in r72028.

Note: See TracTickets for help on using tickets.