Opened 9 years ago

Closed 9 years ago

#24526 closed defect (invalid)

gperf checksum mismatch

Reported by: leonhardt.ralph@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: jpnurmi@…
Port: gperf

Description (last modified by jmroot (Joshua Root))

Checksum mismatch for gperf:

ralph-leonhardts-macbook-air:/ ralphleonhardt$ sudo port clean --all gperf
Password:
--->  Cleaning gperf
ralph-leonhardts-macbook-air:/ ralphleonhardt$ sudo port install gsed autoconf213 bzip2 libtool libxml2 mhash pcre pkgconfig readline zlib t1lib 
--->  Computing dependencies for gsed
--->  Fetching gperf
--->  Attempting to fetch gperf-3.0.4.tar.gz from ftp://ftp.chg.ru/pub/gnu/gperf
--->  Verifying checksum(s) for gperf
Error: Checksum (md5) mismatch for gperf-3.0.4.tar.gz
Error: Checksum (sha1) mismatch for gperf-3.0.4.tar.gz
Error: Checksum (rmd160) mismatch for gperf-3.0.4.tar.gz
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: The following dependencies failed to build: gettext libiconv gperf ncurses ncursesw
Error: Status 1 encountered during processing.
Before reporting a bug, first run the command again with the -d flag to get complete output.
ralph-leonhardts-macbook-air:/ ralphleonhardt$ 

Change History (9)

comment:1 Changed 9 years ago by leonhardt.ralph@…

Cc: leonhardt.ralph@… added

Cc Me!

comment:2 Changed 9 years ago by jpnurmi@…

Cc: jpnurmi@… added

Cc Me!

comment:3 Changed 9 years ago by jpnurmi@…

DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/gperf
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/gperf
DEBUG: OS Platform: darwin
DEBUG: OS Version: 10.3.0
DEBUG: Mac OS X Version: 10.6
DEBUG: System Arch: i386
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/muniversal-1.0.tcl
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant darwin is not provided by port gperf.
DEBUG: Requested variant i386 is not provided by port gperf.
DEBUG: Requested variant macosx is not provided by port gperf.
--->  Computing dependencies for gperf
DEBUG: Executing org.macports.main (gperf)
DEBUG: Skipping completed org.macports.fetch (gperf)
--->  Verifying checksum(s) for gperf
DEBUG: Executing org.macports.checksum (gperf)
--->  Checksumming gperf-3.0.4.tar.gz
Error: Checksum (md5) mismatch for gperf-3.0.4.tar.gz
Portfile checksum: gperf-3.0.4.tar.gz md5 c1f1db32fb6598d6a93e6e88796a8632
Distfile checksum: gperf-3.0.4.tar.gz md5 8441312daf01c97a2ba4331b4f32467f
Error: Checksum (sha1) mismatch for gperf-3.0.4.tar.gz
Portfile checksum: gperf-3.0.4.tar.gz sha1 e32d4aff8f0c730c9a56554377b2c6d82d0951b8
Distfile checksum: gperf-3.0.4.tar.gz sha1 85b8c44964a70a63d751afa5906796a0417e64ce
Error: Checksum (rmd160) mismatch for gperf-3.0.4.tar.gz
Portfile checksum: gperf-3.0.4.tar.gz rmd160 aeaed644501d2424f88d203dd68c997b6a90f116
Distfile checksum: gperf-3.0.4.tar.gz rmd160 314ba4cbfa3bb782f76b5e5e6f3d6d6a5a28de70
The correct checksum line may be:
checksums           md5     8441312daf01c97a2ba4331b4f32467f \
                    sha1    85b8c44964a70a63d751afa5906796a0417e64ce \
                    rmd160  314ba4cbfa3bb782f76b5e5e6f3d6d6a5a28de70
Error: Target org.macports.checksum returned: Unable to verify file checksums
DEBUG: Backtrace: Unable to verify file checksums
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for gperf): org.macports.activate org.macports.extract org.macports.checksum org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

comment:4 Changed 9 years ago by jmroot (Joshua Root)

Cc: leonhardt.ralph@… removed
Description: modified (diff)
Keywords: gperf removed
Owner: changed from macports-tickets@… to mcalhoun@…
Priority: HighNormal
Summary: gperfgperf checksum mismatch

Please remember to preview and use WikiFormatting, cc the maintainer, and use a summary that describes the issue. As per the ticket guidelines, the High priority is reserved for the use of MacPorts team members. Also note that you do not need to be in cc when you are the reporter.

comment:5 Changed 9 years ago by jpnurmi@…

Hi,

I'd rather consider this as a high priority issue as gperf is a dependency for so many packages. This issue prevents me from installing such crucial packages as mercurial, git-core and subversion via MacPorts to my fresh new OS X installation.

Kind regards, J-P Nurmi

comment:6 Changed 9 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Status: newassigned

I can not seem to reproduce this error.
I tried to download from the same server as your original post but had no problems.
Perhaps it was a temporary glitch.
Could you please try again:

sudo port clean --all gperf
sudo port -d checksum gperf

comment:7 Changed 9 years ago by jpnurmi@…

Excellent! It works now indeed. I did "sudo port clean --all gperf" and tried multiple times before commenting this issue, though.

comment:8 Changed 9 years ago by hashar@…

Similar to http://trac.macports.org/ticket/24514 .

Both bugs can probably be fixed since the .tar.gz got fixed upstream.

comment:9 Changed 9 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.