New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #24571 (closed defect: wontfix)

Opened 4 years ago

Last modified 11 months ago

ghc-6.10.4 segmentation fault in ghci with Text.Regex.Posix

Reported by: waterson@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: ghc

Description

After doing a single operation with Text.Regex.Posix, ghci crashes with a segmentation fault. This on Snow Leopard, using ghc-6.10.4. I was unable to reproduce with the Haskell Platform (6.12.1).

~$ uname -a
Darwin putterwell.bunker.maubi.net 10.3.0 Darwin Kernel Version 10.3.0: Fri Feb 26 11:58:09 PST 2010; root:xnu-1504.3.12~1/RELEASE_I386 i386
~$ ghci
GHCi, version 6.10.4: http://www.haskell.org/ghc/  :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer ... linking ... done.
Loading package base ... linking ... done.
Prelude> :m +Text.Regex.Posix
Prelude Text.Regex.Posix> "foo bar baz bop" =~ "([a-z]+)" :: Bool
Loading package syb ... linking ... done.
Loading package array-0.2.0.0 ... linking ... done.
Loading package bytestring-0.9.1.4 ... linking ... done.
Loading package regex-base-0.72.0.2 ... linking ... done.
Loading package regex-posix-0.72.0.3 ... linking ... done.
True
Prelude Text.Regex.Posix> Segmentation fault
~$ 

Attachments

ghc_2011-04-30-024901_Conall.crash (3.6 KB) - added by jmr@… 3 years ago.

Change History

comment:1 Changed 4 years ago by macsforever2000@…

  • Owner changed from macports-tickets@… to gwright@…

comment:2 Changed 4 years ago by gwright@…

  • Status changed from new to assigned

comment:3 Changed 3 years ago by jmr@…

  • Status changed from assigned to closed
  • Resolution set to worksforme

Can't reproduce.

comment:4 Changed 3 years ago by jmr@…

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Sorry, I misread the steps to reproduce. I'm attaching the crash log.

Changed 3 years ago by jmr@…

comment:5 Changed 21 months ago by raimue@…

  • Owner changed from gwright@… to macports-tickets@…

Port abandoned, #35561.

comment:6 Changed 11 months ago by cal@…

  • Status changed from reopened to closed
  • Resolution set to wontfix

This ticket is obsolete, since GHC has been updated since.

Note: See TracTickets for help on using tickets.