Opened 11 years ago

Closed 11 years ago

#24755 closed defect (duplicate)

avidemux: Fails to build

Reported by: mkae (Marko Käning) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: avidemux

Description

Looks like 64 bit is a problem here:

---

markos-imac:~ marko$ sudo port -v build avidemux
Password:
--->  Computing dependencies for avidemux.
--->  Building avidemux
[  1%] Built target ADM_filter
[  1%] Building CXX object avidemux/ADM_userInterfaces/ADM_commonUI/CMakeFiles/ADM_commonUI.dir/GUI_sdlRenderHelper.o
[  2%] Built target ADM_script
[  2%] Building CXX object avidemux/ADM_videoFilter/CMakeFiles/ADM_videoFilter.dir/ADM_vidDeintASM.o
/var/tmp//cc0RpiB0.s:103:suffix or operands invalid for `push'
/var/tmp//cc0RpiB0.s:104:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:104:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:105:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:105:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:106:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:106:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:107:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:107:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:126:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:126:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:128:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:128:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:133:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:133:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:134:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:134:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:137:suffix or operands invalid for `pop'
/var/tmp//cc0RpiB0.s:197:suffix or operands invalid for `push'
/var/tmp//cc0RpiB0.s:198:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:198:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:199:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:199:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:200:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:200:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:201:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:201:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:220:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:220:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:222:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:222:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:227:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:227:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:228:32-bit absolute addressing is not supported for x86-64
/var/tmp//cc0RpiB0.s:228:cannot do signed 4 byte relocation
/var/tmp//cc0RpiB0.s:231:suffix or operands invalid for `pop'
make[2]: *** [avidemux/ADM_videoFilter/CMakeFiles/ADM_videoFilter.dir/ADM_vidDeintASM.o] Error 1
make[1]: *** [avidemux/ADM_videoFilter/CMakeFiles/ADM_videoFilter.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:6: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m: In function 'initSdlCocoaView':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:80: error: 'nsView' undeclared (first use in this function)
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:80: error: (Each undeclared identifier is reported only once
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:80: error: for each function it appears in.)
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:82: error: 'NSQuickDrawView' undeclared (first use in this function)
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:108: warning: cast from pointer to integer of different size
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:108: warning: format '%ld' expects type 'long int', but argument 5 has type 'int'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m: In function 'destroyCocoaView':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4/avidemux/ADM_userInterfaces/ADM_commonUI/GUI_sdlRenderHelper.m:125: error: 'nsView' undeclared (first use in this function)
make[2]: *** [avidemux/ADM_userInterfaces/ADM_commonUI/CMakeFiles/ADM_commonUI.dir/GUI_sdlRenderHelper.o] Error 1
make[1]: *** [avidemux/ADM_userInterfaces/ADM_commonUI/CMakeFiles/ADM_commonUI.dir/all] Error 2
make: *** [all] Error 2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_avidemux/work/avidemux_2.4.4" && /usr/bin/make -j2 all " returned error 2
Warning: the following items did not execute (for avidemux): org.macports.build
Error: Status 1 encountered during processing.
Before reporting a bug, first run the command again with the -d flag to get complete output.

Change History (1)

comment:1 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #21371.

Note: See TracTickets for help on using tickets.