Opened 11 years ago

Closed 9 years ago

#24951 closed defect (wontfix)

kismet-2010-01-R1 build failure on Tiger

Reported by: fabien.essely@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: tiger Cc: ryandesign (Ryan Schmidt)
Port: kismet

Description

The first in the build process : error: nested functions are disabled, use -fnested-functions to re-enable.

The log file is obtain with : sudo port -d install kismet

Attachments (4)

kismetbuilderror.log (14.6 KB) - added by fabien.essely@… 11 years ago.
kismetbug.log (3.2 KB) - added by fabien.essely@… 11 years ago.
tiger-main.log (16.9 KB) - added by ryandesign (Ryan Schmidt) 10 years ago.
leopard-main.log (36.7 KB) - added by ryandesign (Ryan Schmidt) 10 years ago.

Download all attachments as: .zip

Change History (20)

Changed 11 years ago by fabien.essely@…

Attachment: kismetbuilderror.log added

comment:1 Changed 11 years ago by fabien.essely@…

Cc: fabien.essely@… added

Cc Me!

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Cc: fabien.essely@… removed
Owner: changed from macports-tickets@… to snc@…

Please remember to cc the maintainer, and note that you do not need to be in cc when you are the reporter.

comment:3 Changed 11 years ago by jmroot (Joshua Root)

This looks the same as #23096. The comments there seem to say it was fixed, but the ticket was never closed.

comment:4 in reply to:  3 Changed 11 years ago by fabien.essely@…

Replying to jmr@…:

This looks the same as #23096. The comments there seem to say it was fixed, but the ticket was never closed.

The Portfile was modified to contain "configure.env-append CFLAGS=-fnested-functions" as recommended, but it doesn't work on this release (2010-01-R1).

comment:5 Changed 11 years ago by jmroot (Joshua Root)

That should be configure.cflags-append for one thing.

comment:6 Changed 11 years ago by nerdling (Jeremy Lavergne)

Status: newassigned

changed it to configure.cflags in r67926.

Changed 11 years ago by fabien.essely@…

Attachment: kismetbug.log added

comment:7 in reply to:  6 Changed 11 years ago by fabien.essely@…

Replying to snc@…:

changed it to configure.cflags in r67926.

File "kismetbug.log" is obtained with the new portfile. Nested-functions seem to be disable.

comment:8 Changed 11 years ago by nerdling (Jeremy Lavergne)

Is this an issue for you in 2010-07-R1?

comment:9 in reply to:  8 Changed 11 years ago by fabien.essely@…

Replying to snc@…:

Is this an issue for you in 2010-07-R1?

No, I encounter the same bug.

comment:10 Changed 10 years ago by nerdling (Jeremy Lavergne)

Hmm, it just built successfully for me: Darwin Kernel Version 9.8.0 root:xnu-1228.15.4~1/RELEASE_PPC Power Macintosh (ppc7450 w/ gcc-4.0).

Can you post the results of these, just in case something funky is up?

machine
uname -a
ls -l /usr/bin/gcc

comment:11 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: tiger added
Summary: kismet-2010-01-R1 build failurekismet-2010-01-R1 build failure on Tiger

Darwin 9 (what Jeremy tested with) is quite a different operating system from Darwin 8 (what the reporter has). I can confirm kismet 2010-07-R1 builds fine on my Power Mac G4 with Leopard, but not when booted to Tiger. I'll attach both logs.

I don't think this software respects CFLAGS, because I don't see -fnested-functions in the compile line.

Changed 10 years ago by ryandesign (Ryan Schmidt)

Attachment: tiger-main.log added

Changed 10 years ago by ryandesign (Ryan Schmidt)

Attachment: leopard-main.log added

comment:12 Changed 10 years ago by nerdling (Jeremy Lavergne)

Ryan, there's a new kismet out. Would you mind testing it on Tiger later today?

comment:13 Changed 10 years ago by nerdling (Jeremy Lavergne)

Updated to 2011-01-R1 in r75282.

comment:14 Changed 10 years ago by nerdling (Jeremy Lavergne)

I tried using -fnested-functions to no avail. You'll note the error no longer complains about the -fnested-functions but continues to fail.

cc1plus: warning: command line option "-fnested-functions" is valid for C/ObjC but not for C++
/usr/bin/g++-4.0 -I/opt/local/include -fnested-functions -I/usr/include/ncurses -Wall -pipe -O2 -arch ppc -c darwin_control_wrapper.m -o darwin_control_wrapper.mo 
darwin_control_wrapper.m: In function 'darwin_set_channel':
darwin_control_wrapper.m:203: warning: unused variable 'err'
darwin_control_wrapper.m: In function 'darwin_get_channels':
darwin_control_wrapper.m:242: error: syntax error before 'in'
darwin_control_wrapper.m:229: warning: unused variable 'x'
darwin_control_wrapper.m: At top level:
darwin_control_wrapper.m:246: warning: type defaults to 'int' in declaration of 'ret_channels'
darwin_control_wrapper.m:246: error: 'ret' undeclared here (not in a function)
darwin_control_wrapper.m:246: warning: data definition has no type or storage class
darwin_control_wrapper.m:248: warning: type defaults to 'int' in declaration of 'x'
darwin_control_wrapper.m:248: error: 'supported' undeclared here (not in a function)
darwin_control_wrapper.m:248: warning: data definition has no type or storage class
darwin_control_wrapper.m:250: error: parse error before 'return'
gnumake: *** [darwin_control_wrapper.mo] Error 1

comment:15 Changed 10 years ago by nerdling (Jeremy Lavergne)

You can try modifying the various configure.XXXflags-append -fnested-functions.

Somewhere I remember seeing the cflags being set to the cppflags.

If you get a patch, feel free to send it.

comment:16 Changed 9 years ago by nerdling (Jeremy Lavergne)

Resolution: wontfix
Status: assignedclosed

I have no means of supporting Tiger. If you have patches open a ticket, submit them, and I'll add them.

Note: See TracTickets for help on using tickets.