Opened 10 years ago

Closed 10 years ago

#25010 closed defect (duplicate)

Checksum mismatch on ncftp

Reported by: kentaro.kawamoto@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: ncftp

Description (last modified by ryandesign (Ryan Schmidt))

seems like checksum hasn't been updated properly.

% sudo port  install ncftp
--->  Computing dependencies for ncftp
--->  Verifying checksum(s) for ncftp
Error: Checksum (md5) mismatch for ncftp-3.2.4-src.tar.bz2
Error: Checksum (sha1) mismatch for ncftp-3.2.4-src.tar.bz2
Error: Checksum (rmd160) mismatch for ncftp-3.2.4-src.tar.bz2
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Status 1 encountered during processing.
Before reporting a bug, first run the command again with the -d flag to get complete output.

Change History (2)

comment:1 Changed 10 years ago by kentaro.kawamoto@…

fixed format and replaced with the output of debug mode.

% sudo port -d install ncftp
...
--->  Verifying checksum(s) for ncftp
DEBUG: Executing org.macports.checksum (ncftp)
--->  Checksumming ncftp-3.2.4-src.tar.bz2
Error: Checksum (md5) mismatch for ncftp-3.2.4-src.tar.bz2
Portfile checksum: ncftp-3.2.4-src.tar.bz2 md5 216d6befdd7381b11ffdc8b6e0c1bd12
Distfile checksum: ncftp-3.2.4-src.tar.bz2 md5 bc4af9801f626d541f0bf6b7ac4dae1f
Error: Checksum (sha1) mismatch for ncftp-3.2.4-src.tar.bz2
Portfile checksum: ncftp-3.2.4-src.tar.bz2 sha1 7e149123c45e1628882c0866c3ebea3ba37f9929
Distfile checksum: ncftp-3.2.4-src.tar.bz2 sha1 bd4b6381dadc8189bc13e615696438e5390772cd
Error: Checksum (rmd160) mismatch for ncftp-3.2.4-src.tar.bz2
Portfile checksum: ncftp-3.2.4-src.tar.bz2 rmd160 7ae4f66e4c644bdfdf3ed7556f268141f70644a4
Distfile checksum: ncftp-3.2.4-src.tar.bz2 rmd160 aa666933321fbc2aeede7301acbc4a79074f25d2
The correct checksum line may be:
checksums           md5     bc4af9801f626d541f0bf6b7ac4dae1f \
                    sha1    bd4b6381dadc8189bc13e615696438e5390772cd \
                    rmd160  aa666933321fbc2aeede7301acbc4a79074f25d2
Error: Target org.macports.checksum returned: Unable to verify file checksums
DEBUG: Backtrace: Unable to verify file checksums
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for ncftp): org.macports.activate org.macports.extract org.macports.checksum org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: ncftp removed
Port: ncftp added
Resolution: duplicate
Status: newclosed

Duplicate of #24938.

Note: See TracTickets for help on using tickets.