Opened 11 years ago

Closed 11 years ago

#25084 closed defect (worksforme)

webkit-gtk 1.1.15.4 build failed

Reported by: tbanchuin@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: webkit-gtk

Description

I cannot install the port "webkit-gtk". The installation failed at the building step with the following errors:

Error 1
make: *** [all] Error 2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_webkit-gtk/work/webkit-1.1.15.4" && /usr/bin/make -j2 all " returned error 2
DEBUG: Backtrace: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_webkit-gtk/work/webkit-1.1.15.4" && /usr/bin/make -j2 all " returned error 2
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 9)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for webkit-gtk): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.


The full log output is attached.

Attachments (1)

webkit-gtk.txt (210.0 KB) - added by tbanchuin@… 11 years ago.
full log output

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by tbanchuin@…

Attachment: webkit-gtk.txt added

full log output

comment:1 Changed 11 years ago by tbanchuin@…

Btw, I am running Snow Leopard 10.6.3 and Xcode 3.2.

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Cc: myschizobuddy@… added
Keywords: webkit-gtk build failure failed make error removed
Owner: changed from macports-tickets@… to devans@…

Please remember to cc the maintainers.

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Looks just like #25004, which was supposedly fixed. Have you selfupdated lately?

comment:4 Changed 11 years ago by tbanchuin@…

Cc: tbanchuin@… added

Cc Me!

comment:5 Changed 11 years ago by tbanchuin@…

I just recently installed MacPorts. It's the latest version. I just tried to run selfupate as well, and got the following output:

--->  Updating the ports tree
--->  Updating MacPorts base sources using rsync
MacPorts base version 1.8.2 installed,
MacPorts base version 1.8.2 downloaded.
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated

comment:6 in reply to:  5 Changed 11 years ago by tbanchuin@…

ic...maybe I am not installing version 1.2.1 of webkit-gtk. I will check that and report back.

Replying to tbanchuin@…:

I just recently installed MacPorts. It's the latest version. I just tried to run selfupate as well, and got the following output:

--->  Updating the ports tree
--->  Updating MacPorts base sources using rsync
MacPorts base version 1.8.2 installed,
MacPorts base version 1.8.2 downloaded.
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated

comment:7 Changed 11 years ago by tbanchuin@…

Looking at the attached log again. I am still installing version 1.1.15.4. Should not the port file be updated by the "port update" command though?

Thank you.

comment:8 Changed 11 years ago by myschizobuddy@…

Cc: myschizobuddy@… removed

Cc Me!

comment:9 Changed 11 years ago by tbanchuin@…

Ok, I did not run the "port upgrade outdated" command. Please forgive a newbie. Thanks.

comment:10 Changed 11 years ago by tbanchuin@…

Cc: tbanchuin@… removed

Cc Me!

comment:11 Changed 11 years ago by tbanchuin@…

Cc: tbanchuin@… added

Cc Me!

comment:12 Changed 11 years ago by mf2k (Frank Schima)

Cc: tbanchuin@… removed
Resolution: worksforme
Status: newclosed

Glad you got it working.

Note: See TracTickets for help on using tickets.