Opened 7 years ago

Closed 7 years ago

#25204 closed defect (duplicate)

libgdiplus build failed on snow lepoard

Reported by: yanflao@… Owned by: stechert@…
Priority: Normal Milestone:
Component: ports Version: 1.9.0
Keywords: Cc:
Port: libgdiplus

Description (last modified by ryandesign (Ryan Schmidt))

Mac os x 10.6.3
xcode 2.2.3

mono 2.4.3 can be installed but with the x86_32 arch, so leading to failure of gnome-sharp2 which needs the mono 2.6. see complete information in attached file (mono 2.6 failure).

can anyone suggest to install gnome-sharp2?

ld: warning: in /opt/local/lib/libcairo.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libpixman-1.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
dsymutil .libs/libgdiplus.0.0.0.dylib || :
warning: no debug symbols in executable (-arch x86_64)
warning: no debug symbols in executable (-arch i386)
(cd .libs && rm -f libgdiplus.0.dylib && ln -s libgdiplus.0.0.0.dylib libgdiplus.0.dylib)
(cd .libs && rm -f libgdiplus.dylib && ln -s libgdiplus.0.0.0.dylib libgdiplus.dylib)
ar cru .libs/libgdiplus.a  adjustablearrowcap.o bitmap.o brush.o carbon-private.o customlinecap.o dstream.o font.o general.o graphics.o graphics-cairo.o graphics-metafile.o graphics-path.o graphics-pathiterator.o hatchbrush.o icocodec.o image.o imageattributes.o lineargradientbrush.o matrix.o metafile.o pathgradientbrush.o pen.o print.o region.o region-bitmap.o region-path-tree.o solidbrush.o stringformat.o text.o text-cairo.o text-pango.o text-metafile.o texturebrush.o bmpcodec.o emfcodec.o emfplus.o gifcodec.o jpegcodec.o pngcodec.o tiffcodec.o wmfcodec.o
ranlib .libs/libgdiplus.a
ranlib: for architecture: x86_64 file: .libs/libgdiplus.a(text-pango.o) has no symbols
ranlib: for architecture: i386 file: .libs/libgdiplus.a(text-pango.o) has no symbols
creating libgdiplus.la
(cd .libs && rm -f libgdiplus.la && ln -s ../libgdiplus.la libgdiplus.la)
Making all in tests
/usr/bin/gcc-4.2 -DHAVE_CONFIG_H -I. -I.. -I.. -I../src -I../src -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include   -I/opt/local/include/cairo -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/libpng12    -I/opt/local/include   -I/opt/local/include/freetype2 -I/opt/local/include   -I/opt/local/include   -I/opt/local/include    -I/opt/local/include  -no-cpp-precomp -O2 -arch x86_64 -arch i386 -lpthread -c testgdi.c
i686-apple-darwin10-gcc-4.2.1: -lpthread: linker input file unused because linking not done
i686-apple-darwin10-gcc-4.2.1: -lpthread: linker input file unused because linking not done
/bin/sh ../libtool --tag=CC   --mode=link /usr/bin/gcc-4.2  -no-cpp-precomp -O2 -arch x86_64 -arch i386 -lpthread  -flat_namespace -undefined suppress -L/opt/local/lib -arch x86_64 -arch i386 -o testgdi testgdi.o ../src/libgdiplus.la -lfontconfig 
mkdir .libs
/usr/bin/gcc-4.2 -no-cpp-precomp -O2 -arch x86_64 -arch i386 -flat_namespace -undefined suppress -arch x86_64 -arch i386 -o .libs/testgdi testgdi.o  -L/opt/local/lib ../src/.libs/libgdiplus.dylib -lpthread /opt/local/lib/libglib-2.0.dylib -lresolv /opt/local/lib/libcairo.dylib /opt/local/lib/libpixman-1.dylib /opt/local/lib/libXrender.dylib /opt/local/lib/libtiff.dylib /opt/local/lib/libjpeg.dylib /opt/local/lib/libgif.dylib /opt/local/lib/libSM.dylib /opt/local/lib/libICE.dylib /opt/local/lib/libX11.dylib /opt/local/lib/libXau.dylib /opt/local/lib/libXdmcp.dylib /opt/local/lib/libpng12.dylib /opt/local/lib/libexif.dylib /opt/local/lib/libintl.dylib -lc -lm /opt/local/lib/libfontconfig.dylib /opt/local/lib/libiconv.dylib /opt/local/lib/libfreetype.dylib -lz /opt/local/lib/libexpat.dylib 
ld: warning: duplicate dylib /opt/local/lib/libz.1.dylib
ld: warning: in /opt/local/lib/libcairo.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: in /opt/local/lib/libpixman-1.dylib, file was built for unsupported file format which is not the architecture being linked (i386)
ld: warning: duplicate dylib /opt/local/lib/libz.1.dylib
ld: in /opt/local/lib/libxslt.1.dylib, file was built for unsupported file format which is not the architecture being linked (i386) for architecture i386
collect2: ld returned 1 exit status
lipo: can't open input file: /var/tmp//ccdrL5g0.out (No such file or directory)
make[2]: *** [testgdi] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libgdiplus/work/libgdiplus-2.6" && /usr/bin/make all " returned error 2
Error: Target org.macports.build returned: shell command failed
DEBUG: Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for libgdiplus): org.macports.destroot org.macports.build
Log for libgdiplus is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libgdiplus/main.log
DEBUG: couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
Error: Unable to upgrade port: 1
DEBUG: upgrade libgdiplus failed
    while executing
"macports::_upgrade_mport_deps $mport $target"
    (procedure "mportexec" line 36)
    invoked from within
"mportexec $workername $target"
Error: Unable to execute port: upgrade libgdiplus failed
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

mono_2.6_install.txt (127.2 KB) - added by yanflao@… 7 years ago.
mono 2.6

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by yanflao@…

mono 2.6

comment:1 Changed 7 years ago by jmroot (Joshua Root)

  • Cc jean-philippe.humbert@… macports@… bgrupe@… dcestari@… hvitved@… adrian@… d.czerwonk@… ac90b671@… rgabo@… snc@… celil.rufat@… macports@… dports@… kibiz0r@… rob@… deesto@… matt@… domiman@… andreas@… p_ansell@… reid@… motya@… sgaragagghu@… s.bonczkowski@… leafyoung@… ryandesign@… removed
  • Owner changed from macports-tickets@… to stechert@…
  • Port libgdiplus added; gnome-sharp2 mono removed
  • Summary changed from gnome-sharp2 depending on mono build failed on snow lepoard to libgdiplus build failed on snow lepoard

Removing the giant cc list since no explanation was given for it. You should normally just cc the maintainer of the port.

comment:2 in reply to: ↑ description Changed 7 years ago by ryandesign (Ryan Schmidt)

  • Description modified (diff)

Replying to yanflao@…:

xcode 2.2.3

Did you mean 3.2.2?

mono 2.4.3 can be installed but with the x86_32 arch

I'm not sure what you mean here. First, the current version of the mono port is 2.6.4; if you see 2.4.3, then your ports are out of date and you should use "sudo port selfupdate" to update. Second, x86_64 is the default arch on Snow Leopard for 64-bit capable machines. i386 is the other arch available. There is no such arch as x86_32.

It sounds like you are trying to build libgdiplus for i386 but its dependencies have not been built for i386:

ld: warning: in /opt/local/lib/libcairo.dylib, file was built for unsupported file format which is not the architecture being linked (i386) ld: warning: in /opt/local/lib/libpixman-1.dylib, file was built for unsupported file format which is not the architecture being linked (i386)

Rebuild cairo and dependencies so they contain the i386 architecture. You could either build for i386 only, or probably preferable rebuild with the universal variant so they contain both i386 and x86_64:

sudo port upgrade --enforce-variants cairo +universal

ld: in /opt/local/lib/libxslt.1.dylib, file was built for unsupported file format which is not the architecture being linked (i386) for architecture i386

Rebuild libxslt and dependencies with the universal variant:

sudo port upgrade --enforce-variants libxslt +universal

comment:3 follow-up: Changed 7 years ago by ryandesign (Ryan Schmidt)

Revision: I see now you're trying to build libgdiplus universal, so yes, you should build its dependencies universal too.

comment:4 in reply to: ↑ 3 Changed 7 years ago by yanflao@…

sorry for my mistake xcode is 3.2.2

the problem cannot be reproduced after I uninstall all and reinstall macports. The libgdiplus and the mon 2.6.4 can be now installed on my snow leopard. But problems are still there as similar as the 25210, because I want to install the gnom-sharp2.

Replying to ryandesign@…:

Revision: I see now you're trying to build libgdiplus universal, so yes, you should build its dependencies universal too.

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24501.

Note: See TracTickets for help on using tickets.