Opened 11 years ago

Closed 11 years ago

#25327 closed defect (duplicate)

gcc-mp-4.3: Internal error compiling R packages

Reported by: raramayo (Rodolfo Aramayo) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: kjell.konis@…, mww@…
Port: gcc43 R

Description (last modified by jmroot (Joshua Root))

When trying to upgrade my Bioconductor 'R' packages using MacPorts I run into the following:

* installing *source* package ‘IRanges’ ...
** libs
/opt/local/bin/gcc-mp-4.3 -std=gnu99 -I/opt/local/lib/R/include  -I/opt/local/include    -fPIC  -O2 -m32 -c AEbufs.c -o AEbufs.o
dyld: Library not loaded: /opt/local/lib/libmpfr.1.dylib
  Referenced from: /opt/local/libexec/gcc/i386-apple-darwin9/4.3.5/cc1
  Reason: image not found
gcc-mp-4.3: Internal error: Trace/BPT trap (program cc1)
Please submit a full bug report.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [AEbufs.o] Error 1
ERROR: compilation failed for package ‘IRanges’
...
...
...

* installing *source* package ‘limma’ ...
** libs
/opt/local/bin/gcc-mp-4.3 -std=gnu99 -I/opt/local/lib/R/include  -I/opt/local/include    -fPIC  -O2 -m32 -c normexp.c -o normexp.o
dyld: Library not loaded: /opt/local/lib/libmpfr.1.dylib
  Referenced from: /opt/local/libexec/gcc/i386-apple-darwin9/4.3.5/cc1
  Reason: image not found
gcc-mp-4.3: Internal error: Trace/BPT trap (program cc1)
Please submit a full bug report.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [normexp.o] Error 1
ERROR: compilation failed for package ‘limma’
...
...
...

* installing *source* package ‘RSQLite’ ...
checking for gcc... /opt/local/bin/gcc-mp-4.3 -std=gnu99
checking for C compiler default output file name... rm: a.out.dSYM: is a directory

configure: error: C compiler cannot create executables
See `config.log' for more details.
ERROR: configuration failed for package ‘RSQLite’
...
...
...

* installing *source* package ‘Biostrings’ ...
** libs
/opt/local/bin/gcc-mp-4.3 -std=gnu99 -I/opt/local/lib/R/include  -I/opt/local/include -I"/Users/raramayo/R/i386-apple-darwin9.8.0-library/2.11/IRanges/include"   -fPIC  -O2 -m32 -c BAB_class.c -o BAB_class.o
dyld: Library not loaded: /opt/local/lib/libmpfr.1.dylib
  Referenced from: /opt/local/libexec/gcc/i386-apple-darwin9/4.3.5/cc1
  Reason: image not found
gcc-mp-4.3: Internal error: Trace/BPT trap (program cc1)
Please submit a full bug report.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [BAB_class.o] Error 1
ERROR: compilation failed for package ‘Biostrings’

Change History (2)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Cc: kjell.konis@… mww@… added
Description: modified (diff)
Keywords: gcc Bioconductor removed
Port: gcc43 added

Please remember to preview and use WikiFormatting, and to cc the maintainer(s).

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #25258.

Note: See TracTickets for help on using tickets.