Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#25489 closed defect (fixed)

Building Amarok Fails

Reported by: sa00044@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: strassh@…, skiskywalker@…, oliver@…
Port: Amarok

Description (last modified by ryandesign (Ryan Schmidt))

I am trying to install Amarok and during the building process I get the following:

Error: Target org.macports.build returned: shell command failed
Log for amarok is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Here is the log. I am using Snow Leopard 10.6.4

Attachments (9)

main.log (388.6 KB) - added by sa00044@… 10 years ago.
Amarok Build Log
main_new.log (370.3 KB) - added by sa00044@… 10 years ago.
Amarok New Log
main_gcc43.log.zip (89.5 KB) - added by sa00044@… 10 years ago.
amarok.log (19.8 KB) - added by strassh@… 10 years ago.
Look like I have the same error, I have cleaned amarok and also updated my ports
main.2.log (194.6 KB) - added by strassh@… 10 years ago.
And here is the main.log file (the previous file was the output of "port install amarok")
main.3.log (175.5 KB) - added by skiskywalker@… 10 years ago.
I'm under the impression that I should attach this log file. Just so you know, I ran "sudo port install amarok" twice just in case it magically worked the second time. I dunno if that affects the log file at all...!
main.tar.bz2 (25.6 KB) - added by skiskywalker@… 10 years ago.
amarok-Portfile_try1.diff (1.1 KB) - added by michaelld (Michael Dickens) 10 years ago.
Portfile diff for amarok to resolve 32/64 bit pointer issue, try 1.
main.4.log (201.5 KB) - added by strassh@… 10 years ago.
main.log from amarok compilation after the first patch amarok-Portfile_try1.diff

Download all attachments as: .zip

Change History (50)

Changed 10 years ago by sa00044@…

Attachment: main.log added

Amarok Build Log

comment:1 Changed 10 years ago by michaelld (Michael Dickens)

Owner: changed from macports-tickets@… to michaelld@…
Status: newassigned

I removed the patch because it didn't seem necessary; looks like it was! I'll fix the patch & check that in & you can try again. Hopefully this single patch will do it. I'll post back when the fixes are in place.

comment:2 Changed 10 years ago by michaelld (Michael Dickens)

Committed in r69350; please 'sudo port sync' and then try installing again.

comment:3 in reply to:  2 Changed 10 years ago by sa00044@…

Replying to michaelld@…:

Committed in r69350; please 'sudo port sync' and then try installing again.

Just started building again.

Thanks again. I'll get back to you soon.

comment:4 Changed 10 years ago by sa00044@…

Error: Target org.macports.build returned: shell command failed
Log for amarok is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

New log attached.

Changed 10 years ago by sa00044@…

Attachment: main_new.log added

Amarok New Log

comment:5 Changed 10 years ago by michaelld (Michael Dickens)

Did you do "sudo port sync" first?

comment:6 in reply to:  5 ; Changed 10 years ago by sa00044@…

Replying to michaelld@…:

Did you do "sudo port sync" first?

Sure I did! I even did sudo port selfupdate and gave it another try but still the same.

A couple of minutes ago, I tried sudo port upgrade all. This time gcc43 failed. Here is the gcc43 log

Changed 10 years ago by sa00044@…

Attachment: main_gcc43.log.zip added

comment:7 in reply to:  6 Changed 10 years ago by sa00044@…

Replying to sa00044@…:

Replying to michaelld@…:

Did you do "sudo port sync" first?

Sure I did! I even did sudo port selfupdate and gave it another try but still the same.

A couple of minutes ago, I tried sudo port upgrade all. This time gcc43 failed. Here is the gcc43 log

Sorry, I meant sudo port upgrade outdated, not upgrade all

comment:8 Changed 10 years ago by sewebster@…

I've noticed sometimes that updates don't get propagated through "port selfupdate" instantaneously (~30 mins delay?)... not sure if port sync is different. Also don't know if this makes sense, or if it is the problem here.

comment:9 Changed 10 years ago by michaelld (Michael Dickens)

My bad; I forgot the 'clean' step. Do "sudo port clean amarok" then try again. That will hopefully take care of amarok.

As for GCC, I'm not a maintainer (in any sense) of it; please search open tickets to see if any are applicable & if not create a new ticket for that issue.

I think some upgrades don't work because the port doesn't get cleaned first & hence the upgrade starts from some unknown point.

comment:10 in reply to:  9 Changed 10 years ago by sa00044@…

Replying to michaelld@…:

My bad; I forgot the 'clean' step. Do "sudo port clean amarok" then try again. That will hopefully take care of amarok.

As for GCC, I'm not a maintainer (in any sense) of it; please search open tickets to see if any are applicable & if not create a new ticket for that issue.

I think some upgrades don't work because the port doesn't get cleaned first & hence the upgrade starts from some unknown point.

Tried once again sudo port sync and got for the first time the following message: "Portfile changed since last build; discarding previous state."

Maybe this time something has indeed changed?

comment:11 Changed 10 years ago by michaelld (Michael Dickens)

That's a good sign -- discarding is the same as cleaning. I hope it works for you this time, but if not post another log & we'll try to work it out.

comment:12 in reply to:  11 ; Changed 10 years ago by sa00044@…

Replying to michaelld@…:

That's a good sign -- discarding is the same as cleaning. I hope it works for you this time, but if not post another log & we'll try to work it out.

Thanks. I'll leave it build overnihgt (it's already past midnight here) and get back in the morning.

Changed 10 years ago by strassh@…

Attachment: amarok.log added

Look like I have the same error, I have cleaned amarok and also updated my ports

Changed 10 years ago by strassh@…

Attachment: main.2.log added

And here is the main.log file (the previous file was the output of "port install amarok")

comment:13 Changed 10 years ago by strassh@…

Cc: strassh@… added

Cc Me!

comment:14 in reply to:  12 Changed 10 years ago by sa00044@…

Replying to sa00044@…:

Replying to michaelld@…:

That's a good sign -- discarding is the same as cleaning. I hope it works for you this time, but if not post another log & we'll try to work it out.

Thanks. I'll leave it build overnihgt (it's already past midnight here) and get back in the morning.

Amarok installed! Thanks again!

comment:15 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: assignedclosed

Short night? You're welcome! I'm closing this ticket as fixed in r69350.

comment:16 in reply to:  15 Changed 10 years ago by sa00044@…

Replying to michaelld@…:

Short night? You're welcome! I'm closing this ticket as fixed in r69350.

One last question:

So, I have indeed installed Amarok. How do I run it now? I can see an Amarok icon in the Applications/Macports/KDE4 folder but when I click on it, Amarok doesn't start. The icon just bounces for some time on the dock and then freezes. Should I do something else?

comment:17 Changed 10 years ago by skiskywalker@…

Resolution: fixed
Status: closedreopened

Sorry to bother everyone but I get the same error message as sa00044@… did when trying to build Amarok. I'm using Mac OS X 10.5.8 with X11 2.5.0 and I keep them up-to-date. I've successfully used MacPorts to install and use things like Bash Completion and even Gimp in the past but when things go wrong I'm quite helpless. I would be very grateful if you could help. MacPorts said:

--->  Building amarok
Error: Target org.macports.build returned: shell command failed
Log for amarok is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/main.log
Error: Status 1 encountered during processing.

Changed 10 years ago by skiskywalker@…

Attachment: main.3.log added

I'm under the impression that I should attach this log file. Just so you know, I ran "sudo port install amarok" twice just in case it magically worked the second time. I dunno if that affects the log file at all...!

comment:18 Changed 10 years ago by skiskywalker@…

Cc: skiskywalker@… added

Cc Me!

comment:19 Changed 10 years ago by skiskywalker@…

Cc: skiskywalker@… removed

Cc Me!

comment:20 Changed 10 years ago by skiskywalker@…

Cc: skiskywalker@… added

Cc Me!

comment:21 Changed 10 years ago by michaelld (Michael Dickens)

Hi skiskywalker@… - Please do the following:

sudo port sync
sudo port clean amarok
sudo port install amarok

and let this ticket know if you are successful. You have the same issue as the original ticket, which was hopefully fixed. My bet is that you just need to update 'port's local copy of the Portfile (on your computer).

comment:22 in reply to:  21 Changed 10 years ago by strassh@…

Replying to michaelld@…:

Hi skiskywalker@… - Please do the following:

sudo port sync
sudo port clean amarok
sudo port install amarok

and let this ticket know if you are successful. You have the same issue as the original ticket, which was hopefully fixed. My bet is that you just need to update 'port's local copy of the Portfile (on your computer).

I have done all the commands above and I still have the same issue. See main.2.log and amarok.log attached to this bug to see my output. Thanks to follow this bug.

comment:23 Changed 10 years ago by skiskywalker@…

I've done as you asked, michaelld, and I'm afraid Amarok still fails to build on my Leopard. I'll upload the new log file in a moment.

Changed 10 years ago by skiskywalker@…

Attachment: main.tar.bz2 added

comment:24 Changed 10 years ago by michaelld (Michael Dickens)

@skiskywalker: The issue is similar to the previous one (same place), but slightly different (I think there's an unwanted header file being read). I'll look into it & get back, hopefully Tuesday but it might be Wednesday.

Changed 10 years ago by michaelld (Michael Dickens)

Attachment: amarok-Portfile_try1.diff added

Portfile diff for amarok to resolve 32/64 bit pointer issue, try 1.

comment:25 Changed 10 years ago by michaelld (Michael Dickens)

Can anyone (having issues or not) try the attached patch? Here's how I would use it (I'll assume you downloaded it to your Downloads area, and have 'sudo' privileges, so change those as needed):

$ pushd `port dir amarok`
$ sudo patch -p0 < ~/Downloads/amarok-Portfile_try1.diff
$ sudo port clean amarok
$ sudo port -f build amarok

and see if that works (then, you can 'popd' to get back to where you were). I've fixed at least some of the issues, but I might be introducing one in the process (I moved from a patch file to doing a global search / replace on a generic term instead of specialized term). Thanks!

comment:26 Changed 10 years ago by strassh@…

I'm having (apparently) the same issue. See main.4.log I just attached for the log file.

But as I'm using a second MacPort installation for kde4 stuffs, I might not have patched the file correctly.

Changed 10 years ago by strassh@…

Attachment: main.4.log added

main.log from amarok compilation after the first patch amarok-Portfile_try1.diff

comment:27 Changed 10 years ago by michaelld (Michael Dickens)

@strassh: From the log file, looks like you did patch the Portfile correctly. The issue is that cmake isn't finding 'mysql' correctly. If you do

port installed | grep sql

and post what's returned. It is possible that you have some variant of mysql installed that isn't compatible with this version of amarok.

comment:28 Changed 10 years ago by strassh@…

I have :

mysql5 @5.1.48_0 (active) mysql5-server @5.1.48_1 (active) sqlite3 @3.6.23.1_0 (active)

do you see anything wrong ?

comment:29 Changed 10 years ago by michaelld (Michael Dickens)

@skiskywalker : You have the same issue as in tickets #22037, #22152, #23544, and #23617. I've closed those tickets out (as duplicates) and am keeping this one going since all of the issues are the same: how to get 32/64 bit compatibility from "long" type by moving it to "void*" or (as Apple recommends) "SRefCon" for just the AppleEvent parts. My patch to the Portfile hopefully does the latter, but I can't test it right now as 64-bit since I don't have that capability (I'm using 10.5 i386 only), nor as 32-bit since my qt4-mac port installation is messed up while I fix tickets #25459 and #20199. Hence, my asking anyone on this ticket to please test it out and report back.

comment:30 Changed 10 years ago by michaelld (Michael Dickens)

@strassh : that all looks good. I'm trying to figure out if there's a 'config.log'-like file you could post, but I won't know until tonight. Can you do:

pushd `port dir amarok`/work/amarok-2.3.1`

and then 'ls' and look for a log file?

comment:31 Changed 10 years ago by michaelld (Michael Dickens)

Sorry:

pushd `port dir amarok`/work/amarok-2.3.1

no trailing `.

comment:32 Changed 10 years ago by strassh@…

Strange, "find" does not find any *.log file in this directory (or any subdirectories).

comment:33 Changed 10 years ago by michaelld (Michael Dickens)

@strassh : Hmm ... I'm not familiar enough with cmake & qmake to know where to look. I'll get to this issue tonight or Wednesday, after I get qt4-mac fixed. In the mean time, can you do

$ which mysql_config5

and if it returns "/opt/local/bin/mysql_config5", then do:

$ mysql_config5

which will return a bunch of config info about mysql -- can you post that here? If the 'which' doesn't work then that tells me something :)

comment:34 Changed 10 years ago by strassh@…

Here :

$ mysql_config5
Usage: /opt/macports-test/bin/mysql_config5 [OPTIONS]
Options:
        --cflags         [-I/opt/macports-test/include/mysql5/mysql  -pipe -fPIC    -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT  -DDONT_DECLARE_CXA_PURE_VIRTUAL]
        --include        [-I/opt/macports-test/include/mysql5/mysql]
        --libs           [-L/opt/macports-test/lib   -L/opt/macports-test/lib/mysql5/mysql -lmysqlclient -L/opt/macports-test/lib -lz -lm  -L/opt/macports-test/lib/ -lssl -lcrypto]
        --libs_r         [-L/opt/macports-test/lib   -L/opt/macports-test/lib/mysql5/mysql -lmysqlclient_r -L/opt/macports-test/lib -lz -lm   -L/opt/macports-test/lib/ -lssl -lcrypto]
        --plugindir      [/opt/macports-test/lib/mysql5/mysql/plugin]
        --socket         [/opt/macports-test/var/run/mysql5/mysqld.sock]
        --port           [0]
        --version        [5.1.48]
        --libmysqld-libs [-L/opt/macports-test/lib   -L/opt/macports-test/lib/mysql5/mysql -lmysqld -ldl  -L/opt/macports-test/lib -lz -lm     -L/opt/macports-test/lib/ -lssl -lcrypto]

comment:35 Changed 10 years ago by michaelld (Michael Dickens)

@strassh: OK; so I take it that ${prefix} for your installation is "/opt/macports-test", i.e., if you do "which port" then it returns "/opt/macports-test/bin/port"? Do you have MacPorts installed anywhere else (e.g., also "/opt/local")?

comment:36 Changed 10 years ago by strassh@…

Yes, indeed I have (as I said on the post right after your post about the patch), I have a port installation for kde3 stuffs (I use kmymoney which isn't yet in macport in it's kde4 version) in /opt/local and an other (for kde4 stuffs) in /opt/macports-test

But maybe I do things wrong, in my $PATH I only have "/opt/local/bin" (among other typical stuffs) maybe that's the problem.

In all commands involving "port" that you have me to type, I have replaced "port" by "/opt/macports-test/bin/port" in order to use the right "port" binary. But "which port" give me "/opt/local/port" and "which mysql_config5" give me nothing...

What is the right way to use 2 installations ? Do I have to alter $PATH during installation process ?

comment:37 Changed 10 years ago by oliver@…

Cc: oliver@… added

Cc Me!

comment:38 Changed 10 years ago by michaelld (Michael Dickens)

@strassh: I would be that it's your dual install that's the issue. I find it difficult to keep track of which has what installed, so I gave my "second" one up just a few weeks ago & moved entirely to the "primary". I've found no great way to have 2 installed 'port' areas. The best I've come up with is to create 2 directories in /opt -- in your case, say, "kde3" and "kde4" -- and then create a link to the one you're interested in at any given time -- so, if you wanted to use kde3 stuff you'd do "cd /opt && sudo rm -f local && sudo ln -s kd3 local"; if you wanted to use kde4 stuff you'd do "cd /opt && sudo rm -f local && sudo ln -s kd4 local". I'd make a script to handle this switching, installed into both /opt/local/bin's. $PATH would remain as you have it. This way has the nuisance of having to switch back and forth, but it keeps the basic /opt/local path nice and clean no matter which is installed, and you cannot in general execute anything in the non-linked subdirectory because everything is expecting to be located in /opt/local . Hope this helps!

comment:39 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:40 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: reopenedclosed

Hopefully fixed in r69497. It works for my on 10.5 i386, in the sense of compiling and installing. For those who actually want to -use- Amarok :), maybe someone can shed light on ticket #25578. I'm closing this ticket, but please reopen if you still have the original issue after doing:

$ sudo port sync
$ sudo port upgrade amarok

Please note that qt4-mac will also be upgraded, so please give yourself plenty of time for the upgrade -- and, if you're using special variants on qt4-mac then you probably want to do that upgrade separately (see, e.g., ticket #25459 last comment).

comment:41 Changed 10 years ago by skiskywalker@…

Sorry I didn't reply yesterday; I was a bit busy. I also tried the patch and Amarok did compile for me, but I thought I'd done something wrong (and was trying to understand what) because I couldn't get Amarok to start. I ran the dbus-related commands in Terminal but some of them produced error messages, so now I'll keep an eye on ticket #25578 as recommended. I'm also waiting for the new Amarok and qt4-mac updates to compile. The main thing is: thanks for the help so far!

Note: See TracTickets for help on using tickets.