Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#2559 closed defect (fixed)

imapfilter duplicate path error in Portfile

Reported by: filippo@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: josh@…
Port:

Description

using:

reinplace "s|${prefix}/|\${DESTDIR}/${prefix}/|g" ${worksrcpath}/Makefile

in Portfile will result in duplicate path in Makefile with this result at compile time:

cc -I/opt/local/include -Wall -O -DMAKEFILE_SHAREDIR='"/opt/localopt/local/share/imapfilter"' -I/usr/local/include -c -o auth.o auth.c

and thus imapfilter not working, removing the line does the trick

Change History (4)

comment:1 Changed 15 years ago by blb@…

Owner: changed from darwinports-bugs@… to mww@…

Assign to imapfilter port maintainer.

comment:2 Changed 15 years ago by mww@…

Resolution: fixed
Status: newclosed

thanks - fixed!

comment:3 Changed 15 years ago by mww@…

Cc: josh@… added

comment:4 Changed 15 years ago by mww@…

* Bug 2652 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.