Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#25606 closed defect (duplicate)

dsniff 2.3 build error

Reported by: vh3@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: dsniff arpspoof Cc: hsivank@…
Port: dsniff

Description

Mac OS X 10.6.4 Xcode 3.2.3

i tried several installations, cleanups and tips mentioned in other Tickets (like cleaning /usr/local) but I always get the same error message shown in the following log. All dependent pgk´s are ok and up to date. No other Ports are installed. If you need any Information I´ll be glad to distribute it. Thanks in advance :-)

:info:configure creating Makefile
:info:configure creating config.h
:msg:configure --->  Building dsniff
:debug:build build phase started at Fri Jul  9 21:53:25 CEST 2010
:debug:build Executing org.macports.build (dsniff)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsniff/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsniff/work/dsniff-2.3" && /usr/bin/make -j2 all'
:info:build /usr/bin/gcc-4.2 -pipe -O2 -DBIND_8_COMPAT -arch x86_64 -D_BSD_SOURCE -DHAVE_SOCKADDR_SA_LEN -DLIBNET_BSDISH_OS -DLIBNET_BSD_BYTE_SWAP -DDSNIFF_LIBDIR=\"/opt/local/lib/\" -I. -I/opt/local/include -I/opt/local/include -I/opt/local/include  -I/opt/local/include  -I./missing -c ./missing/dummy.c
:info:build /usr/bin/gcc-4.2 -pipe -O2 -DBIND_8_COMPAT -arch x86_64 -D_BSD_SOURCE -DHAVE_SOCKADDR_SA_LEN -DLIBNET_BSDISH_OS -DLIBNET_BSD_BYTE_SWAP -DDSNIFF_LIBDIR=\"/opt/local/lib/\" -I. -I/opt/local/include -I/opt/local/include -I/opt/local/include  -I/opt/local/include  -I./missing -c ./missing/md5.c
:info:build /usr/bin/gcc-4.2 -pipe -O2 -DBIND_8_COMPAT -arch x86_64 -D_BSD_SOURCE -DHAVE_SOCKADDR_SA_LEN -DLIBNET_BSDISH_OS -DLIBNET_BSD_BYTE_SWAP -DDSNIFF_LIBDIR=\"/opt/local/lib/\" -I. -I/opt/local/include -I/opt/local/include -I/opt/local/include  -I/opt/local/include  -I./missing -c ./arpspoof.c
:info:build ./arpspoof.c:25: warning: 'struct ether_addr' declared inside parameter list
:info:build ./arpspoof.c:25: warning: its scope is only this definition or declaration, which is probably not what you want
:info:build ./arpspoof.c:26: warning: 'struct ether_addr' declared inside parameter list
:info:build ./arpspoof.c: In function 'arp_send':
:info:build ./arpspoof.c:49: warning: passing argument 1 of 'libnet_get_hwaddr' from incompatible pointer type
:info:build ./arpspoof.c:49: error: too many arguments to function 'libnet_get_hwaddr'
:info:build ./arpspoof.c:60: warning: passing argument 6 of 'libnet_build_ethernet' from incompatible pointer type
:info:build ./arpspoof.c:60: error: too few arguments to function 'libnet_build_ethernet'
:info:build ./arpspoof.c:64: error: 'ETH_H' undeclared (first use in this function)
:info:build ./arpspoof.c:64: error: (Each undeclared identifier is reported only once
:info:build ./arpspoof.c:64: error: for each function it appears in.)
:info:build ./arpspoof.c:64: error: too few arguments to function 'libnet_build_arp'
:info:build ./arpspoof.c:67: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
:info:build ./arpspoof.c:71: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
:info:build ./arpspoof.c:73: warning: format '%s' expects type 'char *', but argument 4 has type 'int'
:info:build ./arpspoof.c:73: warning: format '%s' expects type 'char *', but argument 5 has type 'int'
:info:build ./arpspoof.c:77: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
:info:build ./arpspoof.c:78: warning: format '%s' expects type 'char *', but argument 4 has type 'int'
:info:build ./arpspoof.c:80: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
:info:build ./arpspoof.c: In function 'arp_find':
:info:build ./arpspoof.c:114: warning: passing argument 2 of 'arp_cache_lookup' from incompatible pointer type
:info:build ./arpspoof.c: In function 'main':
:info:build ./arpspoof.c:181: warning: assignment makes pointer from integer without a cast
:info:build make: *** [arpspoof.o] Error 1
:info:build make: *** Waiting for unfinished jobs....
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsniff/work/dsniff-2.3" && /usr/bin/make -j2 all " returned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for dsniff): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for dsniff is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsniff/main.log

Change History (4)

comment:1 Changed 11 years ago by hsivank@…

Hello vh3,

You should build libnids against libnet ... ( or install dnsiff-devel )

anyway you can try this

remove libnids and libnet11

sudo port uninstall libnids
sudo port uninstall libnet11

apply this patch to libnids portfile's

--- Portfile.orig	2010-07-10 02:48:59.000000000 +0200
+++ Portfile	2010-07-10 02:41:11.000000000 +0200
@@ -20,7 +20,7 @@
                  sha1    105bff0d0d35ab95ec90cce98cfb409f64ed44b4 \
                  rmd160  38994ad04f688291315bfcde38d8795e7a4c4226
 
-depends_lib      port:libpcap port:libnet11
+depends_lib      port:libpcap port:libnet
 
 configure.args   --mandir=${prefix}/share/man --disable-libglib

now you can install dsniff

sudo port install dsniff

;-)

comment:2 Changed 11 years ago by hsivank@…

Cc: hsivank@… added

Cc Me!

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #23971.

comment:4 Changed 11 years ago by vh3@…

Hi,

thanks, after a little bit of investigating how to patch the portfile it´s working now. If someone has the same issues it´s worth mentioning, that you have to do a port clean (for dsniff) otherwise you´l encounter other strange errors. So thanx again for your fast and competent help.

cu Volker

Note: See TracTickets for help on using tickets.