Opened 10 years ago

Closed 10 years ago

#25670 closed defect (fixed)

qca sometimes fails to activate

Reported by: bgrupe27 Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: qca

Description (last modified by ryandesign (Ryan Schmidt))

Hi,

I have encountered a strange bug:

qca sometimes fails to activate with the following message:

can't create directory "/opt/local/share/qt4": no such file or directory

the directory *is* there and filled with files. Once you rename it (along with the /opt/local/share/kde4 dir), it will happily activate without creating new directories or files in there though.

If qca was once successfully activated, it will successfully activate again even after an uninstall and reinstall.

Change History (6)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: rowue@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to rowue@…

comment:2 Changed 10 years ago by michaelld (Michael Dickens)

Very strange. Can you attached a log file -- either debugging ("port -d ...") output or the main.log found in build directory when you encounter this failure (not of success)? I can't replicate this error.

comment:3 Changed 10 years ago by rowue@…

It would also be nice if you give some hint which OSX you use (10.4, 10.5, 10.6) this might help tracking the error. (Perhaps we should add this as an flag to trac.)

comment:4 Changed 10 years ago by bgrupe27

I'm sorry I omitted that, I'm testing on an iMac and a MacBookPro both running uptodate patched 10.6.4 with XCode 3.2.3.

The strange thing is that I cannot reliably reproduce this once I have worked around this issue (which I have since I'm doing some more tests which result in other tickets currently ;-) )

The only reliable way to reproduce is to uninstall macports, reinstall ist and install qca on a clean macports.

What I did try was to manually run the command

mkdir -p /opt/local/share/qt4

when it's already there and it resulted in the same error message

maybe a test -z could fix it either way?

comment:5 Changed 10 years ago by michaelld (Michael Dickens)

Owner: changed from rowue@… to michaelld@…

I'm updating the port QCA to install into ${qt_dir} [default: ${prefix}/libexec/qt4-mac ] and sub-directories. Maybe that will take care of this issue, and IMHO this change needs to be done anyway.

comment:6 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

I've just checked in changes that hopefully address this issue, in r70436. Please "sync", "clean", and then try installing again. I'm closing this ticket; please reopen if the original issue isn't addressed for you.

Note: See TracTickets for help on using tickets.