Opened 10 years ago

Closed 10 years ago

#25769 closed enhancement (fixed)

RFE: build doxygen with universal and build_arch support

Reported by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: universal Cc: jmroot (Joshua Root)
Port: doxygen

Description

Attached is a proposal to add universal support to doxygen.
This may be a duplicate of #17550 or #21552.

Parallel build caused problems as well, as in #22127.

Attachments (1)

Portfile.diff (3.5 KB) - added by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez) 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Attachment: Portfile.diff added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

#22127 has been fixed by setting 'use_parallel_build no' only when building the docs.

comment:2 Changed 10 years ago by cssdev

Status: newassigned

I only have 1 Mac with limited space, so I don't use universal builds. So a parallel universal build doesn't work?

comment:3 Changed 10 years ago by jmroot (Joshua Root)

The parallel build problem was completely separate to the universal build problem. The former has been fixed, the latter remains. The patch attached here was trying to fix both. If you apply it, you'll want to remove the unnecessary use_parallel_build no that it adds.

comment:4 Changed 10 years ago by hahn.seb@…

Using the patch and afterwards removeing use_parallel_build no worked like a charm for me trying to install doxygen on SL using i386 arch

comment:5 Changed 10 years ago by jmroot (Joshua Root)

Cc: jmr@… added
Summary: RFE: build doxygen with universal supportRFE: build doxygen with universal and build_arch support

Patch works for me. Note that it also makes the port obey build_arch. Do you mind if one of us commits it?

comment:6 Changed 10 years ago by cssdev

No objections from me, thanks for verifying the patch works!

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.