Opened 10 years ago

Closed 10 years ago

#25884 closed defect (worksforme)

failure in py26-matplotlib-basemap @1.0_0 ; does not install dbflib

Reported by: jpringle@… Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: py26-matplotlib-basemap

Description (last modified by skymoo (Adam Mercer))

I upgrade macports with self update, and then update all packages. py26-matplotlib and py26-matplotlib-basemap were updated to version one. The command

   import  mpl_toolkits.basemap

Then failed with "ImportError: No module named dbflib" at

/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/mpl_toolkits/basemap/__init__.py in <module>()
     36 from matplotlib.lines import Line2D
     37 from matplotlib.transforms import Bbox
---> 38 import pyproj, sys, os, math, dbflib
     39 from proj import Proj
     40 import numpy as np

I tried uninstalling and then installing basemap again, and it did not help. I think dbflib is supposed to be part of basemap; it was part of the py26-matplotlib-basemap package as of version 0.99.4_0

I appreciate any help you can offer.

Cheers, Jamie Pringle University of New Hampshire.

Change History (4)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: jpringle@… removed
Keywords: matplotlib-basemap removed
Owner: changed from macports-tickets@… to ram@…

Please remember to cc the maintainer, and note that you do not need to be in cc when you are the reporter.

comment:2 Changed 10 years ago by skymoo (Adam Mercer)

Description: modified (diff)
Status: newassigned

I can't reproduce this:

$ port installed py26-matplotlib-basemap
The following ports are currently installed:
  py26-matplotlib-basemap @1.0_0 (active)
$ python -c "import mpl_toolikits.basemap"
$ port contents py26-matplotlib-basemap | grep dbflib
  /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/dbflib/__init__.py
  /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/dbflib/__init__.pyc
  /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/dbflib/dbflib.py
  /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/dbflib/dbflib.pyc
  /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/dbflibc.so

Does your version not contain dbflib?

comment:3 Changed 10 years ago by jpringle@…

Ok, this may be a bit of a Heisenbug. I did the following...

>>> port installed py26-matplotlib-basemap
The following ports are currently installed:
  py26-matplotlib-basemap @0.99.4_0
  py26-matplotlib-basemap @1.0_0 (active)

It was odd to have two versions installed, and one active, so I ran the following commands

>>>sudo port uninstall 'py26-matplotlib-basemap@0.99.4_0'
--->  Uninstalling py26-matplotlib-basemap @0.99.4_0

>>> port installed py26-matplotlib-basemap
The following ports are currently installed:
  py26-matplotlib-basemap @1.0_0 (active)

>>> sudo port uninstall py26-matplotlib-basemap
--->  Deactivating py26-matplotlib-basemap @1.0_0
--->  Uninstalling py26-matplotlib-basemap @1.0_0

>>> sudo port install py26-matplotlib-basemap
--->  Computing dependencies for py26-pyobjc
--->  Fetching py26-pyobjc
--->  Attempting to fetch pyobjc-core-2.3.tar.gz from http://lil.fr.distfiles.macports.org/python
--->  Verifying checksum(s) for py26-pyobjc
--->  Extracting py26-pyobjc
--->  Configuring py26-pyobjc
--->  Building py26-pyobjc
--->  Staging py26-pyobjc into destroot
--->  Computing dependencies for py26-pyobjc
--->  Installing py26-pyobjc @2.3_0
--->  Deactivating py26-pyobjc @2.2_0
--->  Activating py26-pyobjc @2.3_0
--->  Cleaning py26-pyobjc
--->  Computing dependencies for py26-pyobjc-cocoa
--->  Fetching py26-pyobjc-cocoa
--->  Attempting to fetch pyobjc-framework-Cocoa-2.3.tar.gz from http://lil.fr.distfiles.macports.org/python
--->  Verifying checksum(s) for py26-pyobjc-cocoa
--->  Extracting py26-pyobjc-cocoa
--->  Configuring py26-pyobjc-cocoa
--->  Building py26-pyobjc-cocoa
--->  Staging py26-pyobjc-cocoa into destroot
--->  Computing dependencies for py26-pyobjc-cocoa
--->  Installing py26-pyobjc-cocoa @2.3_0
--->  Deactivating py26-pyobjc-cocoa @2.2_0
--->  Activating py26-pyobjc-cocoa @2.3_0
--->  Cleaning py26-pyobjc-cocoa
--->  Computing dependencies for py26-matplotlib-basemap
--->  Fetching py26-matplotlib-basemap
--->  Verifying checksum(s) for py26-matplotlib-basemap
--->  Extracting py26-matplotlib-basemap
--->  Configuring py26-matplotlib-basemap
--->  Building py26-matplotlib-basemap
--->  Staging py26-matplotlib-basemap into destroot
--->  Installing py26-matplotlib-basemap @1.0_0
--->  Activating py26-matplotlib-basemap @1.0_0
--->  Cleaning py26-matplotlib-basemap
>>>

I have no idea what caused this behavior, but now it works:

>>> ls /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/db*
/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/dbflibc.so

/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/dbflib:
__init__.py	__init__.pyc	dbflib.py	dbflib.pyc

Alls well that ends well, but I am not sure why this happened.

comment:4 Changed 10 years ago by skymoo (Adam Mercer)

Resolution: worksforme
Status: assignedclosed

Not sure why dbflib wasn't built in the first place... anyway glad it's working now.

Note: See TracTickets for help on using tickets.