Opened 10 years ago

Closed 7 years ago

#25896 closed defect (fixed)

rb19-sqlite3 fails destroot when ruby19 installed with nosuffix variant

Reported by: wsiegrist@… Owned by: singingwolfboy@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: ruby ruby1.9 sqlite3 Cc:
Port: rb19-sqlite3

Description

rb19-sqlite3 fails destroot when ruby19 is installed with the nosuffix variant since it cannot find $prefix/bin/ruby1.9. Perhaps the nosuffix variant needs to lay down some symlinks, or rb19-sqlite3 needs a nosuffix variant to match.

Attachments (1)

main.log (11.8 KB) - added by wsiegrist@… 10 years ago.
Log of port install rb19-sqlite3 when ruby19+nosuffix installed

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by wsiegrist@…

Attachment: main.log added

Log of port install rb19-sqlite3 when ruby19+nosuffix installed

comment:1 Changed 7 years ago by g5pw (Aljaž Srebrnič)

Resolution: fixed
Status: newclosed

Well, it's been 3 years, and it looks like it's working now. Lots of things changed in between, but my guess is this was resolved when ruby_select was created. I'm going to close the ticket as fixed, feel free to reopen it if there's still any issue with rb19-sqlite3.

Note: See TracTickets for help on using tickets.