Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#25907 closed defect (fixed)

libvpx 0.9.1 fails to build on Leopard

Reported by: yaseppochi (Stephen J. Turnbull) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: raimue (Rainer Müller), michaelld (Michael Dickens)
Port: libvpx

Description

This is a /different/ failure than that of #25815.

Apparently gcc-4.0 doesn't like -maltivec, but the configure script for the codecs puts it in the flags, resulting in "can't invoke compiler". I've reproduced the failure from the command line and verified that removing -maltivec from the command line allows gcc to execute. I haven't tried to modify configure.

Attaching main.log and config.err.

Attachments (3)

main.log (4.8 KB) - added by yaseppochi (Stephen J. Turnbull) 10 years ago.
config.err (13.5 KB) - added by yaseppochi (Stephen J. Turnbull) 10 years ago.
typescript-libvpx.gz (1.2 KB) - added by paulbeard@… 10 years ago.
typescript of libvpx building and installing, but w/o using port

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by yaseppochi (Stephen J. Turnbull)

Attachment: main.log added

Changed 10 years ago by yaseppochi (Stephen J. Turnbull)

Attachment: config.err added

comment:1 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

On ppc without universal, it's enabling a bunch of i386 stuff including throwing -arch i386 into CFLAGS ... It's also trying to use the Leopard SDK rather than /

Configuring selected codecs
  enabling vp8_encoder
  enabling vp8_decoder
  enabling x86
  enabling runtime_cpu_detect
  enabling mmx
  enabling sse
  enabling sse2
  enabling sse3
  enabling ssse3
  enabling postproc
Unable to invoke compiler: /usr/bin/gcc-4.0 -pipe -O0 -ggdb3 -arch ppc -isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5 -O3 -Wall -Wdeclaration-after-statement -Wdisabled-optimization -Wpointer-arith -Wcast-qual -Wno-unused -isysroot /Developer/SDKs/MacOSX10.5.sdk -mmacosx-version-min=10.5 -m32 -arch i386 -O3 -Wall -Wdeclaration-after-statement -Wdisabled-optimization -Wpointer-arith -Wcast-qual -Wno-unused

Configuration failed. This could reflect a misconfiguration of your
toolchains, improper options selected, or another problem. If you
don't see any useful error messages above, the next step is to look
at the configure error log file (config.err) to determine what
configure was trying to do when it died.
shell command " cd "/opt/local/var/macports/build/_Users_jeremy_src_macports-trunk_dports_multimedia_libvpx/work/libvpx-0.9.1" && ./configure --prefix=/opt/local --enable-vp8 --enable-psnr --enable-postproc --enable-multithread --enable-runtime-cpu-detect --disable-install-docs " returned error 1

comment:2 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from macports-tickets@… to raimue@…

Changed 10 years ago by paulbeard@…

Attachment: typescript-libvpx.gz added

typescript of libvpx building and installing, but w/o using port

comment:3 Changed 10 years ago by paulbeard@…

I got libvpx to configure, build and install on my ancient system [Darwin gee5.paulbeard.org 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:57:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_PPC Power Macintosh]

But not w/in the port infrastructure. See the typescript attached.

comment:4 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

I have the same issue on 10.5 i386. The generic problem is that, by default, libvpx's 'configure' scripts will install as 'universal' no matter if in the Portfile +universal or "universal_variant no" is set. The particular manifestation is setting both -arch i386 and -arch ppc, as well as some conflicting flags which make GCC error out. The solution is to specify the exact "--target=FOO" to compile for, solely as a single architecture (no universal). I just checked in changes in r70235 that should fix this issue. Please "sync", "clean", and try again & report back. I'm closing this ticket, but please reopen if these changes don't work for you for this specific ticket's issue.

comment:5 Changed 10 years ago by michaelld (Michael Dickens)

Cc: michaelld@… added

Cc Me!

comment:6 Changed 10 years ago by paulbeard@…

Seems to be fixed: fast work.

comment:7 in reply to:  4 Changed 10 years ago by yaseppochi (Stephen J. Turnbull)

Replying to michaelld@…:

Please "sync", "clean", and try again & report back.

I got a clean build and install, as you predicted. Dependencies are also upgrading properly.

Thanks!

comment:8 Changed 10 years ago by michaelld (Michael Dickens)

I'm glad to hear that it's working for for y'all (and, me too)! The upstream on this port has some work to do ...

Note: See TracTickets for help on using tickets.