Opened 10 years ago

Closed 10 years ago

#25919 closed defect (duplicate)

texlive : Internal error (infinite loop)

Reported by: oofyt@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: texlive

Description


Attachments (1)

build.txt.gz (199.5 KB) - added by oofyt@… 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by oofyt@…

Attachment: build.txt.gz added

comment:1 Changed 10 years ago by oofyt@…

Cc: oofyt@… added

Cc Me!

comment:2 Changed 10 years ago by drkp (Dan Ports)

Cc: oofyt@… removed
Owner: changed from macports-tickets@… to dports@…
Port: texlive added
Status: newassigned

comment:3 Changed 10 years ago by drkp (Dan Ports)

This is probably a duplicate of #25836, which has been fixed. A port selfupdate should solve the problem.

comment:4 in reply to:  3 Changed 10 years ago by oofyt@…

I have seen the bug report you mentioned and I did the macports update but i got the same message, as you can see.

MacBook-Pro:~$ sudo port selfupdate
--->  Updating the ports tree
--->  Updating MacPorts base sources using rsync
MacPorts base version 1.9.1 installed,
MacPorts base version 1.9.1 downloaded.
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
MacBook-Pro:~$ sudo port install texlive
--->  Computing dependencies for texliveError: Internal error: port lookup failed: too many nested evaluations (infinite loop?)
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

MacBook-Pro:~$ date
Mon Aug  2 22:48:37 CEST 2010

comment:5 Changed 10 years ago by drkp (Dan Ports)

Yes, this appears to be a different issue. Sorry about that. Looking into it now.

comment:6 Changed 10 years ago by drkp (Dan Ports)

Cc: jeremyhu@… added
Resolution: duplicate
Status: assignedclosed

This is a dependency loop caused by xorg-libXi depending on xmlto. See #25912, which is not yet fixed.

Note: See TracTickets for help on using tickets.