Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#25921 closed defect (duplicate)

circular dependency for diffuse

Reported by: yasir.suhail@… Owned by: tommyd@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: diffuse

Description

I am trying to install diffuse on my Mac OSX 10.6.4. It goes into a circular dependency check. Also, it tries to search for python24 although it should be using python26 (which is standard for many ports and already installed on my system).

Anyway, I run sudo port install diffuse >buildout.txt 2>builderror.txt

I attach the builderror file.

Attachments (2)

builderror.txt.gz (35.0 KB) - added by yasir.suhail@… 10 years ago.
gzipped error file
buildout.txt (107 bytes) - added by yasir.suhail@… 10 years ago.
Output file

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by yasir.suhail@…

Attachment: builderror.txt.gz added

gzipped error file

comment:1 Changed 10 years ago by yasir.suhail@…

Actually, I ran sudo port install -d diffuse >buildout.txt 2>builderror.txt

comment:2 Changed 10 years ago by mf2k (Frank Schima)

Keywords: dependency circular infinite loop removed
Milestone: MacPorts 1.9.2
Owner: changed from macports-tickets@… to tommyd@…
Summary: cicular depedency for diffusecircular dependency for diffuse

Changed 10 years ago by yasir.suhail@…

Attachment: buildout.txt added

Output file

comment:3 Changed 10 years ago by drkp (Dan Ports)

Resolution: duplicate
Status: newclosed

This seems to be the dependency loop caused by xorg-libXi: see #25912

comment:4 Changed 10 years ago by tommyd@…

The reason why this still depends on Python 2.4 and not 2.6 is that this pulls in gcc44 as dependency for me (still on 10.5.8) and I somewhat refused to wait a day to let it compile this huge dependency and everything else... I still consider this some kind of upstream port bug and just didn't came around investigating this more thoroughly.

  py26-gtk
    [...]
    py26-cairo
      py26-numpy
        [...]
        atlas
          gcc44
            gmp
            mpfr
          [...]

comment:5 Changed 10 years ago by mf2k (Frank Schima)

python 2.4 is really old and not preferred for ports anymore. I suggest changing it to py26-gtk and adding variants for python24 and python25 too.

comment:6 in reply to:  5 Changed 10 years ago by tommyd@…

Replying to macsforever2000@…:

python 2.4 is really old and not preferred for ports anymore. I suggest changing it to py26-gtk and adding variants for python24 and python25 too.

Yes this is indeed a good idea - my first port with variants, yay! Done in r70233

comment:7 Changed 10 years ago by yasir.suhail@…

Thanks! It works now!

Note: See TracTickets for help on using tickets.