Opened 11 years ago

Closed 10 years ago

#25956 closed defect (worksforme)

xfig 3.2.5 crashes when accessing the menu multiple times

Reported by: lawrence.ong@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: xfig

Description (last modified by jmroot (Joshua Root))

When the menu is accessed multiple times, the program crashes.

Steps to Reproduce:

  1. Draw some figure and save it as 1.fig
  2. Modify the figure and save it as 2.fig
  3. Open 1.fig, and export it as eps
  4. Open 2.fig, and export it as eps
  5. Keep repeating 3 and 4, the program will crash at some point.

I tried to recompile the xfig without XAW3D, but the problem persists. Both version 3.2.5 and 3.2.5b have this problems.

I don't encounter this problem, however, in Linux.

Change History (6)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Description: modified (diff)
Port: 3.2.5 removed
Priority: HighNormal

comment:2 Changed 11 years ago by lawrence.ong@…

I got this error message in Terminal. Not sure if it helps:

X error trapped - error message follows:
BadMatch (invalid parameter attributes)
Request code: X_GetWindowAttributes
xfig: figure empty or not modified - exiting

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Please remember to use WikiFormatting and to preview before submitting so you can verify your formatting is correct.

I just updated xfig in MacPorts to version 3.2.5b. Please try that version. (I assume you had built xfig 3.2.5b manually before?) If that still doesn't work, have you already reported your findings to the developers of xfig? That would probably be a good idea so they can fix this in their software.

comment:4 Changed 11 years ago by lawrence.ong@…

The problem still persists in the latest version 3.2.5b.

I have reported this problem to XQuartz. I tried to run xfig tunneled from a Linux machine (with xfig installed) via "ssh -X", and I still ran into this problem. The problem does not occur locally on the Linux machine though. So, I suspect that it might be some problem with Mac's implementation of X11.

comment:5 Changed 11 years ago by lawrence.ong@…

I have installed the latest version of XQuartz (2.5.2) and confirm that this problem no longer occurs. So, I think we can probably close this ticket.

X11.app (2.3.5) that is shipped by Apple will give this problem.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.