Opened 11 years ago

Closed 10 years ago

#25958 closed defect (fixed)

pidgin build failure with gcc 4.0

Reported by: hippallium-macports@… Owned by: nefar@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: perl time_t Cc: matthewapeters@…
Port: pidgin

Description

$ sudo port install pidgin
--->  Computing dependencies for pidgin
--->  Building pidgin
Error: Target org.macports.build returned: shell command failed
Log for pidgin is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/main.log
Error: Status 1 encountered during processing.

Attachments (2)

pidgin.log (70.2 KB) - added by hippallium-macports@… 11 years ago.
Log for pidgin is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/main.log
patch-pidgin-Portfile.diff (609 bytes) - added by dbevans (David B. Evans) 11 years ago.
Proposed patch to Portfile

Download all attachments as: .zip

Change History (13)

Changed 11 years ago by hippallium-macports@…

Attachment: pidgin.log added

Log for pidgin is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/main.log

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to nefar@…

Please remember to cc the maintainer.

comment:2 Changed 11 years ago by matthewapeters@…

Cc: matthewapeters@… added

Cc Me!

comment:3 Changed 11 years ago by hippallium-macports@…

It seems that the package for pidgin depend on an Xcode version that is not available for Mac OS Leopard. I have Xcode 3.1.4.

comment:4 Changed 11 years ago by nefar@…

The latest port version is 2.7.3 and it compiled fine for me. I have Xcode version 3.2.3. Maybe you should upgrade to leopard?

comment:5 Changed 11 years ago by hippallium-macports@…

I am already using Leopard. But Xcode 3.2.3 requires Snow Leopard.

I have tried to compile the older Pidgin 2.6.6. It was working in the past but today I get the same error message. It seems that something has changed recently in MacPorts and that affects the port Pidgin.

comment:6 Changed 11 years ago by hippallium-macports@…

I can build pidgin if I pass the option --disable-perl to the configure script.

comment:7 Changed 11 years ago by dbevans (David B. Evans)

Building pidgin also fails for me in this same way on both Leopard and Tiger (ppc) but builds properly on Snow Leopard (x86_64).

This appears to be compiler dependent as configuring the port to use gcc-4.2 on Leopard allows it to build. gcc-4.2 is the default on Snow Leopard and is available but not the default on Snow Leopard. For Tiger, I am using --disable-perl for now although installing gcc42 may be a solution there (I haven't tried this).

Attached is my patch for the Portfile.

Changed 11 years ago by dbevans (David B. Evans)

Attachment: patch-pidgin-Portfile.diff added

Proposed patch to Portfile

comment:8 Changed 10 years ago by list-ener@…

Patch by devans worked for me, Leopard x86_64.

comment:9 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: Cannot build pidginpidgin build failure with gcc 4.0

comment:10 Changed 10 years ago by gokturk.yuksek@…

Please see the Ticket #25092. The problem is essentially caused by the inclusion of file /opt/local/lib/perl5/5.8.9/darwin-2level/CORE/config.h in the build rather than the one in $(top_srcdir). I believe the alternative solution is better because instead of disabling perl support, it simply fixes the problem by including the correct config.h file.

comment:11 Changed 10 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Fix proposed in #25092 committed as part of r74217.

Note: See TracTickets for help on using tickets.