Opened 10 years ago

Closed 10 years ago

#26103 closed defect (fixed)

webalizer 2.21-02 Configure error - --enable-dns ignored, can't find dblib

Reported by: eric.featherstone@… Owned by: mike.mclean@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: eric.featherstone@…
Port: webalizer

Description

I /think/ --enable-dns is the default option, however whether it is present or not it appears to be ignored by configure. Specifically the configure stage output contains:

configure: WARNING: libdb not found.. DNS/GeoDB code disabled!

Note that db47 is already installed by macports because it is listed as a dependency. I believe that the problem is because the db47 headers and libs are installed into ${prefix}/include/db47 & ${prefix}/lib/db47 not ${prefix}/include & ${prefix}/lib

I think I have a solution, though it may be hamfisted. I edited the port file configure.args section:

configure.args          --mandir=${prefix}/share/man \
                        --with-etcdir=${prefix}/etc \
                        --with-gdlib=${prefix}/lib \
                        --with-gd=${prefix}/include \
                        --with-z-inc=${prefix}/include \
                        --with-zlib=${prefix}/lib \
                        --with-db=${prefix}/include/db47 \
                        --with-dblib=${prefix}/lib/db47 \
                        --with-png-inc=${prefix}/include \
                        --with-png=${prefix}/lib

Or if you prefer a diff; the output from rcsdiff (can this be directly used as a patch file?):

RCS file: /opt/local/var/macports/sources/rsync.macports.org/release/ports/www/webalizer/RCS/Portfile,v
retrieving revision 1.1
diff -r1.1 /opt/local/var/macports/sources/rsync.macports.org/release/ports/www/webalizer/Portfile
41a42,43
>                         --with-db=${prefix}/include/db47 \
>                         --with-dblib=${prefix}/lib/db47 \

The relevant output from sudo port configure webalizer is now:

checking db.h usability... yes
checking db.h presence... yes
checking for db.h... yes

...and most importantly of all I /don't/ get the following complaints anymore:

Warning: Invalid keyword 'DNSCache' (webalizer.conf)
Warning: Invalid keyword 'DNSChildren' (webalizer.conf)

This appears to work for me, I don't know if this is general solution. I'm not even 100% sure if the original problem is with macports or the original webalizer.

Hope I've filled out this ticket correctly!

Cheers, Eric.

Change History (3)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Cc: mike.mclean@… removed
Keywords: webalizer dns GeoDB libdb configure removed
Owner: changed from macports-tickets@… to mike.mclean@…

comment:2 Changed 10 years ago by eric.featherstone@…

Cc: eric.featherstone@… added

Cc Me!

comment:3 Changed 10 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: newclosed

You are correct, the only thing that I would add would be to remove those configure args in the +no_dns variant. Since this is broken, I've gone ahead and committed just this fix (and revbump). r72503

Note: See TracTickets for help on using tickets.