Opened 11 years ago

Closed 11 years ago

#26333 closed defect (invalid)

ikiwiki doesn't use installed Subversion

Reported by: geychaner@… Owned by: tommyd@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: ikiwiki

Description

If you install both the ikiwiki and Subversion ports, ikiwiki doesn't use the port version of Subversion. This is really bad if you're trying to pair ikiwiki with an existing Subversion repository on a Leopard machine; the /usr/bin/svn is 1.4.4, while the latest is 1.6.12.

The problem can apparently be fixed right at the top of /opt/local/bin/ikiwiki by changing the PATH variable, but I am still experimenting.

Attachments (1)

ikiwiki.patch (336 bytes) - added by geychaner@… 11 years ago.
Diff to fix the ikiwiki path so that MacPorts is before /usr/bin

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to tommyd@…

Please remember to cc the maintainer.

comment:2 Changed 11 years ago by tommyd@…

Status: newassigned

As I have no use case for such a setup, please post a patch once you got it working. I'll happily apply it to the port then. Thank you!

Changed 11 years ago by geychaner@…

Attachment: ikiwiki.patch added

Diff to fix the ikiwiki path so that MacPorts is before /usr/bin

comment:3 Changed 11 years ago by geychaner@…

The attached diff file fixes ikiwiki so that the MacPorts directory is ahead of /usr/bin, as it is on the standard $PATH. It's still rude of ikiwiki to override the $PATH variable like this; if it needs a directory on the path, it should simply modify the existing $PATH variable, e.g. $ENV{PATH} = '/opt/local/bin:' + $ENV{PATH}

comment:4 Changed 11 years ago by tommyd@…

Thanks for the patch. I asked upstream (http://ikiwiki.info/bugs/ikiwiki_ignores_PATH_environment/) - lets see how it goes. Its easy enough to apply your patch though in case they don't want to change it in their code.

comment:5 Changed 11 years ago by geychaner@…

Having joined the discussion upstream, the right way to solve this is to change the ENV in the ikiwiki wiki setup file, rather than hard-coding a particular PATH into the ikiwiki executable. This can be considered closed - feature, not a bug.

comment:6 Changed 11 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.