Opened 10 years ago

Closed 10 years ago

#26443 closed defect (worksforme)

kdelibs4 @4.4.5 - Build Failure

Reported by: funkphreakz@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: sharky@…, mkae (Marko Käning)
Port: kdelibs4

Description

I'm having problems building kdelibs4 +universal. I searched through the log file and all the errors seem to relate to missing xslt headers? I have attached the log file below.

I'm running Mac OS X 10.6.4 with XCode 3.2.3

Attachments (2)

kdelibs4-debug.log.zip (195.1 KB) - added by funkphreakz@… 10 years ago.
New-Macports-kdelibs4-Debug-Log.txt (586.0 KB) - added by funkphreakz@… 10 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by funkphreakz@…

Attachment: kdelibs4-debug.log.zip added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: snc@… removed
Owner: changed from macports-tickets@… to snc@…

comment:2 Changed 10 years ago by funkphreakz@…

It looks like the headers for libxml were missing from /opt/local/include/ so I copied the headers from /opt/local/include/xml2/xml to /opt/local/include/xml and now that problem seems to have been replaced by this one:

ld: warning: in /Developer/SDKs/MacOSX10.6.sdk/Library/Frameworkslibxml2.framework/libxml2, missing required architecture x86_64 in file

I would've thought that the binaries in the Snow Leopard SDK would have been 64-Bit compatible? Any ideas on what I should do next would be appreciated:)

comment:3 Changed 10 years ago by nerdling (Jeremy Lavergne)

Status: newassigned

Sounds like I'll need to explicitly specify the MacPorts' XML libraries, much like what I did for XSLT.

Changed 10 years ago by funkphreakz@…

comment:4 Changed 10 years ago by funkphreakz@…

Thanks:). That seems to have gotten past that problem, but now I'm getting another error that I can't seem to pinpoint personally. I've added the new debug log in the post above.

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

The error in the new file looks the same:

:info:build ld: warning: in /Developer/SDKs/MacOSX10.6.sdk/Library/Frameworks//libxml2.framework/libxml2, missing required architecture x86_64 in file

comment:6 Changed 10 years ago by funkphreakz@…

D'oh. You're right. I must've forgotten to search for "warning:" as well as "error:". Sorry:)

comment:7 Changed 10 years ago by funkphreakz@…

I went ahead and fixed what seemed to be the relevant lines in the CMakeCache.txt and now it builds.

There is still a problem though, but I'm not sure whether I should file a new ticket. The problem is that now that I've built the binaries for kdelibs4, then kdebase4-runtime and then subsequently amarok, I'm now experiencing problems related to kdeinit4 trying to load /opt/local/lib/libkdecore.5.dylib, but it being the wrong architecture. The contents of the report to Apple are listed below:

Process:         kdeinit4 [60439]
Path:            /opt/local/bin/kdeinit4.app/Contents/MacOS/kdeinit4
Identifier:      kdeinit4
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  Amarok [60436]

Date/Time:       2010-09-20 10:14:02.088 +1000
OS Version:      Mac OS X 10.6.4 (10F569)
Report Version:  6

Interval Since Last Report:          460321 sec
Crashes Since Last Report:           9
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      180926C3-C4BB-4B00-BA1E-281B035C42F6

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /opt/local/lib/libkdecore.5.dylib
  Referenced from: /opt/local/bin/kdeinit4.app/Contents/MacOS/kdeinit4
  Reason: no suitable image found.  Did find:
	/opt/local/lib/libkdecore.5.dylib: mach-o, but wrong architecture

Model: MacBookPro5,4, BootROM MBP53.00AC.B03, 2 processors, Intel Core 2 Duo, 2.53 GHz, 4 GB, SMC 1.49f2

There is also a separate issue is listed here:

Could not start process Cannot talk to klauncher. The name org.kde.klauncher was not provided by any .service files.

comment:8 Changed 10 years ago by nerdling (Jeremy Lavergne)

Can you verify the architectures of the app and the lib? My assumption is i386 ppc for one with the other being x86_64.

file /opt/local/lib/libkdecore.5.dylib
file /opt/local/bin/kdeinit4.app/Contents/MacOS/kdeinit4

comment:9 Changed 10 years ago by funkphreakz@…

Since my last post I have recompiled the libs/executables involved and now it all works. I'm not sure what the archs were before, but I think you might have been right. Thanks for the help:)

comment:10 Changed 10 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:11 Changed 10 years ago by mkae (Marko Käning)

I think this can be set resolved as fixed?!

comment:12 Changed 10 years ago by nerdling (Jeremy Lavergne)

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.