Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26630 closed defect (duplicate)

db46 fails to build

Reported by: ed.hawes@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: naim.z@…
Port: db46

Description (last modified by ryandesign (Ryan Schmidt))

--->  Computing dependencies for wine-devel
--->  Dependencies to be installed: mesa xorg-libXfixes xorg-libX11 xorg-libxcb python26 db46 gdbm openssl sqlite3 xorg-libpthread-stubs xorg-xcb-proto xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXi xorg-libXext xorg-libXmu xorg-libXt xorg-libsm xorg-libice xorg-libXcomposite xorg-compositeproto xorg-libXcursor xorg-renderproto xrender xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto xorg-libXxf86vm xorg-xf86vidmodeproto
--->  Building db46
Error: Target org.macports.build returned: shell command failed
Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log
Error: The following dependencies failed to build: mesa xorg-libXfixes xorg-libX11 xorg-libxcb python26 db46 gdbm openssl sqlite3 xorg-libpthread-stubs xorg-xcb-proto xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXi xorg-libXext xorg-libXmu xorg-libXt xorg-libsm xorg-libice xorg-libXcomposite xorg-compositeproto xorg-libXcursor xorg-renderproto xrender xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto xorg-libXxf86vm xorg-xf86vidmodeproto
Error: Status 1 encountered during processing.

Attachments (1)

main.zip (29.9 KB) - added by uliano@… 10 years ago.
erro logfile

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: db46 added
Summary: Error: Target org.macports.build returned: shell command faileddb46 fails to build

We'll have no idea what the problem is until you attach the main.log file, whose location should have been printed in the error message.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to blair@…

Please remember to cc the maintainer.

comment:3 Changed 10 years ago by naim.z@…

Cc: naim.z@… added

Cc Me!

Changed 10 years ago by uliano@…

Attachment: main.zip added

erro logfile

comment:4 Changed 10 years ago by dejanpekez@…

got the same error when i wanted to install weechat with python variant. the process failed while building db46 for python26.

main.log:

http://ompldr.org/vNXcyNA/main.log

comment:5 Changed 10 years ago by blair (Blair Zajac)

Resolution: duplicate
Status: newclosed

You're going to have to do the debugging work to figure out why the jni.h is missing or cannot be found. The db46 port works for 99% of all MacPorts' users, so it's probably something with the install on your system. You'll have to figure out why and if there's an issue that the db46 can help with, then submit a patch.

Closing as a duplicate of #19951.

comment:6 Changed 10 years ago by dejanpekez@…

is it maybe because of the latest apple java update? any guidance on how to debug this?

Note: See TracTickets for help on using tickets.