Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26659 closed defect (invalid)

geant4 @4.9.3 runtime library problems

Reported by: karl.hauschild@… Owned by: cristiano.fontana@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: geant4

Description

Hi,

I get the following runtime error for geant4.9.3 :

dyld: Library not loaded: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
  Referenced from: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
  Reason: Incompatible library version: vecLib requires version 1.0.0 or later, but libLAPACK.dylib provides version 0.0.0
Trace/BPT trap

This appears to be the same problem reported in https://trac.macports.org/ticket/20487

Similarly :

[hauschild] : otool -L /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib:
	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib (compatibility version 1.0.0, current version 268.0.1)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.0.1)
	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvMisc.dylib (compatibility version 1.0.0, current version 268.0.1)
	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libvDSP.dylib (compatibility version 1.0.0, current version 268.0.1)
	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib (compatibility version 1.0.0, current version 219.0.0)
	/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib (compatibility version 1.0.0, current version 219.0.0)

Other ports with the same (fixed) problem used cmake : eg https://trac.macports.org/ticket/17577.

But I can not see where I would apply this to the geant4 Portfile

Many thanks, Karl Hauschild

Change History (8)

comment:1 Changed 10 years ago by karl.hauschild@…

Cc: karl.hauschild@… added

Cc Me!

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: cristiano.fontana@… karl.hauschild@… removed
Owner: changed from macports-tickets@… to cristiano.fontana@…
Port: geant4 added; geant @4.9.3 removed
Summary: geant4.9.3 runtime library problemsgeant4 @4.9.3 runtime library problems

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Are you setting DYLD_LIBRARY_PATH or something?

comment:4 in reply to:  3 Changed 10 years ago by karl.hauschild@…

Replying to jmr@…:

Are you setting DYLD_LIBRARY_PATH or something?

Yes, I have set

export  DYLD_LIBRARY_PATH=$DYLD_LIBRARY_PATH:/opt/local/lib

But, I have now realised that this interferes with my system libraries. ie. Now if I try and run
[hauschild] : open any_old_file.pdf

I get the same

dyld: Library not loaded: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libLAPACK.dylib
  Referenced from: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/vecLib
  Reason: Incompatible library version: vecLib requires version 1.0.0 or later, but libLAPACK.dylib provides version 0.0.0
Trace/BPT trap

I could of course add "/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A"
to the path, but this just moves the problem to another library

comment:5 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

OK, so this particular problem is caused by your configuration. (There are a number of other tickets open against geant4 of course.)

comment:6 Changed 10 years ago by karl.hauschild@…

Yep, looks I noticed this behaviour after I installed geant4 by coincidence. Just uninstalled it and the problem remains if I have

export  DYLD_LIBRARY_PATH=$DYLD_LIBRARY_PATH:/opt/local/lib

but a change to

export  LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/local/lib

gets back the system functionality of "open". Will have to see what the above change breaks instead.

Will try reinstalling geant

Cheers.

comment:7 Changed 10 years ago by karl.hauschild@…

OK. for closure :

I started by removing atlas which provided the libLAPACK and tried again with the
[hauschild] : open any_old_file.pdf

which then gave another error, remove offending library (and many dependencies before being able to do so)...etc...etc..etc
the the way down to point where mesa was uninstalled. Now these system libraries and /opt/local/lib appear to be living
side by side.

comment:8 Changed 10 years ago by karl.hauschild@…

Note: See TracTickets for help on using tickets.