Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26747 closed defect (worksforme)

gimp-app fails to build 64-bit (again)

Reported by: kstenerud@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: hobbsilla@…
Port: gimp-app

Description (last modified by jmroot (Joshua Root))

This was marked fixed in ticket #21718 but it still fails to build:

Exec/main.c: In function 'AppOpenDocAEHandler':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c:412: error: 'typeFSS' undeclared (first use in this function)
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c:412: error: (Each undeclared identifier is reported only once
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c:412: error: for each function it appears in.)
** BUILD FAILED **


The following build commands failed:
ScriptExec:
	CompileC build/ScriptExec.build/Deployment/ScriptExec.build/Objects-normal/x86_64/main.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c normal x86_64 c com.apple.compilers.gcc.4_2
(1 failure)

Error: Target org.macports.build returned: shell command "cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec" && xcodebuild  -alltargets -configuration Deployment build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.6 ARCHS=x86_64 SDKROOT= " returned error 1
DEBUG: Backtrace: shell command "cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec" && xcodebuild  -alltargets -configuration Deployment build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.6 ARCHS=x86_64 SDKROOT= " returned error 1

Attachments (2)

gimp-install-debug.log (34.0 KB) - added by kstenerud@… 10 years ago.
gimp-build-failure.log (26.9 KB) - added by kstenerud@… 10 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 years ago by dbevans (David B. Evans)

Keywords: gimp removed
Owner: changed from macports-tickets@… to devans@…
Status: newassigned

comment:2 Changed 10 years ago by dbevans (David B. Evans)

I can't reproduce this problem here. Please attach your full debug log (main.log) and any other details that may be specific to your MacPorts installation.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)

Changed 10 years ago by kstenerud@…

Attachment: gimp-install-debug.log added

comment:4 Changed 10 years ago by kstenerud@…

I can't find any main.log so I've attached the result of using the -d option.

comment:5 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: assignedclosed

You clearly haven't selfupdated in a while.

Changed 10 years ago by kstenerud@…

Attachment: gimp-build-failure.log added

comment:6 Changed 10 years ago by kstenerud@…

Resolution: invalid
Status: closedreopened

Ran "sudo port selfupdate"
Then ran "sudo port upgrade outdated" as per instructions from selfupdate.

The build still fails:

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c: In function 'AppOpenDocAEHandler':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c:412: error: 'typeFSS' undeclared (first use in this function)
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c:412: error: (Each undeclared identifier is reported only once
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c:412: error: for each function it appears in.)

Log attached.

comment:7 Changed 10 years ago by dbevans (David B. Evans)

I think you still using an old version of the ScriptExec source. Your build fails with this error:

	/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c:412: error: 'typeFSS' undeclared (first use in this function)

but my main.c has no mention of this symbol on line 412 or anywhere else.

Please do a full clean of gimp-app to remove any cached distfiles and try again

sudo port clean --all gimp-app

comment:8 Changed 10 years ago by kstenerud@…

That fixed it. Thanks alot!

Hmm I can't mark the ticket resolved. I have the choice of one, and only one, option: "leave as reopened".

comment:9 Changed 10 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: reopenedclosed

That's my job. Glad its working for you.

comment:10 Changed 10 years ago by hobbsilla@…

Resolution: worksforme
Status: closedreopened

I'm still experiencing this problem even after updating macports and applying sudo port clean --all to both gimp and gimp-app.

comment:11 Changed 10 years ago by hobbsilla@…

Cc: hobbsilla@… added

Cc Me!

comment:12 Changed 10 years ago by jmroot (Joshua Root)

Then attach some relevant information (log file, Id line from the portfile, ...). Neither the port maintainer nor the original reporter can reproduce the problem, so it's not like just reopening the ticket is going to get it fixed.

comment:13 Changed 10 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: reopenedclosed

Although no direct evidence of an ongoing problem has been presented, there is a possibility that there was a stealth upgrade some time in the past or could be one in the future since the distfiles are unversioned.

Therefore, in r72561, added a versioned dist_subdir for these files and incremented the revision to ensure that everyone concerned does a fresh fetch of the same (current) files.

Again this works for me, the original reporter and others so will close on that basis. Please do not reopen unless you have definite evidence, as jmr has indicated above, that documents the failure so there is something to for us to work with.

comment:14 Changed 10 years ago by jmroot (Joshua Root)

If the distfile had changed, the checksums wouldn't match, so I doubt that's it.

comment:15 Changed 10 years ago by hobbsilla@…

At this time I can't provide any logs since I accidentally deleted my MBR. Once my Mac gets reformatted with a cloned home directory I'll most likely just do a fresh install of MacPorts.

Note: See TracTickets for help on using tickets.