Opened 9 years ago

Closed 6 years ago

#26890 closed defect (fixed)

texlive-fonts-recommended @13822_1+doc : Missing map entries

Reported by: etphipp@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: texlive Cc: mojca (Mojca Miklavec)
Port: texlive-fonts-recommended

Description

While trying to use the palatino fonts from texlive-fonts-recommended, I discovered that the corresponding map entry (upl.map) in

/opt/local/etc/texmf/updmap.d/10texlive-fonts-recommended.cfg

is missing. This causes pdftex or dvips to fail if these fonts are used with an error along the lines of:

kpathsea: Running mktexpk --mfmode ljfour --bdpi 8000 --mag 1+4800/(2*4000) --dpi 12800 uplb8r
mktexpk: don't know how to create bitmap font for uplb8r.

Adding "Map upl.map" to this file, running "sudo /opt/local/libexec/texlive-update-cnf updmap.cfg" followed by "sudo updmap-sys" fixed the problem.

I assume this file is generated from the contents of the Portfile, and it could be fixed by adding the corresponding line there?

Looking at the contents of this port, it appears there may be many more map entries missing, although I haven't tried to use those fonts.

Change History (14)

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to dports@…

Please remember to cc the maintainer.

comment:2 Changed 9 years ago by drkp (Dan Ports)

Status: newassigned

It does look like something is missing.

You're right that the updmap.d file is generated from the portfile. The portfile is generated from the contents of the texlive package database, so this would seem to be an upstream issue. I'd be surprised if they'd simply forgotten some Map lines, so I wonder if we're missing something here...

comment:3 Changed 9 years ago by etphipp@…

I just tried installing Texlive 2010 from Mac Tex on a different machine and had the same issue, so I agree that is likely an upstream issue.

comment:4 Changed 8 years ago by jmroot (Joshua Root)

Still an issue with 23165?

comment:5 Changed 6 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:6 Changed 6 years ago by mojca (Mojca Miklavec)

jmr: most probably this is still a problem or at least it hasn't been "fixed" upstream.

In order to fix this upstream you would need to request a fix to

http://tug.org/svn/texlive/trunk/Master/tlpkg/tlpsrc/palatino.tlpsrc

The file should contain a line

execute addMap upl.map

The only other duplicate names are in 8r-base.map which is used by ConTeXt. (I don't know whether this would conflict with ConTeXt, but in case it would I'm sure that the ConTeXt would find a way to avoid the problem.)

I have commit rights for upstream, but I don't dare touching it until I get the feedback about whether it is missing by a pure mistake or on purpose. I asked the TeX Live developers about this.

Once we get the feedback from TL developers, this can be fixed in MacPorts as well. The important part is to make sure that it won't need extra care when upgrading to TL 2014.

comment:7 Changed 6 years ago by mojca (Mojca Miklavec)

I don't know if Eric is still interested in this issue, but: what source failed to work? Was it a real document or just a test? TL developers were surprised to see the issue because apparently no package tries to load these fonts, so the fonts would have to be loaded manually. The same fonts (with slightly different metrics) apparently come from psnfss and those are usually the ones used by LaTeX packages.

comment:8 Changed 6 years ago by etphipp@…

This was a real document and was triggered by an academic journal style file (I forget which at the moment, probably IJ4UQ or maybe CMAME). This was a while ago though, so it may no longer be relevant.

comment:9 Changed 6 years ago by mojca (Mojca Miklavec)

This is probably not an issue for Elsevier (or at least not any longer) and http://uncertainty-quantification.com/forauthors/ (IJ4UQ) shouldn't trigger this problem either (at least not at the moment). They do use palatino, but if I compile a sample document it takes the fonts that are "properly installed", not the ones listed in upl.map.

comment:10 Changed 6 years ago by etphipp@…

It is very likely IJ4UQ fixed their style file (I believe it was a brand new journal when this issue arose), so for at least my usage this isn't relevant anymore. It's not clear to me if it should be fixed anyway.

comment:12 Changed 6 years ago by mojca (Mojca Miklavec)

This has been fixed upstream. The only question is: is it worth going through the trouble of enabling it now or would it suffice to simply wait for the upgrade to 2014 (given that the original reporter doesn't need that any longer)?

comment:13 Changed 6 years ago by etphipp@…

I think you can just wait for the upgrade. This is clearly not a burning issue.

comment:14 Changed 6 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

Normally I'd just leave it for the 2014 update, but since this only touches the map files it's easy enough to apply, and we might as well get it out of the way now...

r112132.

Note: See TracTickets for help on using tickets.