Opened 10 years ago

Closed 10 years ago

#26911 closed defect (fixed)

nautilus @2.30.1 (gnome) build failure

Reported by: theckman@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: nautilus

Description

While doing a "port upgrade outdated" I hit a build error with nautilus. I've tried doing an uninstall / reinstall of nautilus instead, but got the same result. The log file is attached.

The relevant part seems to be

:info:build /usr/bin/make  all-recursive
:info:build Making all in eel
:info:build   CCLD   check-program
:info:build Undefined symbols:
:info:build   "_GDK_DISPLAY", referenced from:
:info:build       _eel_gdk_window_focus in libeel-2.a(eel-gdk-extensions.o)
:info:build ld: symbol(s) not found
:info:build collect2: ld returned 1 exit status
:info:build make[2]: *** [check-program] Error 1
:info:build make[1]: *** [all-recursive] Error 1
:info:build make: *** [all] Error 2
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_nautilus/work/nautilus-2.30.1" && /usr/bin/make -j2 all " returned error 2

Attachments (1)

nautilus.log (2.3 KB) - added by theckman@… 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by theckman@…

Attachment: nautilus.log added

comment:1 Changed 10 years ago by dbevans (David B. Evans)

Owner: changed from macports-tickets@… to devans@…
Status: newassigned

comment:2 Changed 10 years ago by dbevans (David B. Evans)

Port: nautilus added
Resolution: fixed
Status: assignedclosed

Breakage is caused by additional API deprecations in gtk2 2.22. Solution backported from nautilus 2.32 branch is to drop the GTK_DISABLE_DEPRECATED and GDK_DISABLE_DEPRECATED cflags.

Committed in r72550.

Note: See TracTickets for help on using tickets.