Opened 10 years ago

Closed 10 years ago

#26940 closed defect (duplicate)

db46 @4.6.21_6 fails to build JAva problem (db_java_wrap.c)

Reported by: baldrik@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: db46

Description

Fresh install of macports 1.9.1 tried to install git-core and db46 fails to build. OSX 10.6.4 with the very latest Java for 10.6 update 3, which brings the Java version to 1.6.0_22 (is this what has broken things?)

relevant part of log (many more similar errors)

../dist/../libdb_java/db_java_wrap.c:242: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'bt_stat_bt_levels_fid'
:r '__attribute__' before 'keyrange_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:205: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'bt_stat_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:206: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'log_stat_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:207: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'mutex_stat_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:208: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'repmgr_stat_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:209: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'txn_active_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:210: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'lock_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:211: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'dbex_class'
:info:build ../dist/../libdb_java/db_java_wrap.c:212: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'repdupmasterex_class'

Change History (2)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to blair@…
Port: db46 added
Summary: db46 db46 @4.6.21_6 fails to build JAva problem (db_java_wrap.c)db46 @4.6.21_6 fails to build JAva problem (db_java_wrap.c)

Please remember to fill in the Port field and cc the maintainer.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #26939; please search before filing new tickets.

Note: See TracTickets for help on using tickets.