Opened 10 years ago

Closed 10 years ago

#26944 closed defect (duplicate)

db46 failed to install

Reported by: mzruya@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: db46

Description (last modified by jmroot (Joshua Root))

using macos 10.6.4 with the latest xcode

../dist/../libdb_java/db_java_wrap.c:9739: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9771: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9796: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9819: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9842: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9867: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'jobject'
../dist/../libdb_java/db_java_wrap.c:9899: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9920: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9943: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:9966: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'jstring'
../dist/../libdb_java/db_java_wrap.c:9991: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'jint'
../dist/../libdb_java/db_java_wrap.c:10010: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:10046: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
../dist/../libdb_java/db_java_wrap.c:10071: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'void'
/bin/sh ./libtool --mode=compile /usr/bin/gcc-4.2 -c -I. -I../dist/.. -I/opt/local/include -pipe -O2 -arch x86_64  ../dist/../db_checkpoint/db_checkpoint.c
make: *** [db_java_wrap.lo] Error 1
make: *** Waiting for unfinished jobs....
 /usr/bin/gcc-4.2 -c -I. -I../dist/.. -I/opt/local/include -pipe -O2 -arch x86_64 ../dist/../db_checkpoint/db_checkpoint.c  -fno-common -DPIC -o .libs/db_checkpoint.o
 /usr/bin/gcc-4.2 -c -I. -I../dist/.. -I/opt/local/include -pipe -O2 -arch x86_64 ../dist/../db_checkpoint/db_checkpoint.c -o db_checkpoint.o >/dev/null 2>&1
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/work/db-4.6.21/build_unix" && /usr/bin/make -j2 all " returned error 2
Error: Target org.macports.build returned: shell command failed
Warning: the following items did not execute (for db46): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log
Error: The following dependencies failed to build: texlive-bin gd2 xpm xorg-libXext xorg-libX11 xorg-libxcb python26 db46 gdbm openssl readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice ghostscript libidn libpaper tiff openmotif Xft2 xrender xorg-renderproto xbitmaps xorg-libXmu xorg-libXp xorg-printproto poppler curl curl-ca-bundle gtk2 atk gtk-doc gnome-doc-utils py26-libxml2 rarian getopt gdk-pixbuf2 jasper pango cairo libpixman shared-mime-info xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto xorg-libXrandr xorg-randrproto lcms openjpeg poppler-data t1lib texlive-common texlive-documentation-base
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (2)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: tex removed
Milestone: MacPorts 1.9.2
Owner: changed from macports-tickets@… to blair@…
Port: db46 added; texlive removed

Please remember to preview and use WikiFormatting, put the name of the port that actually failed in the Port field, and cc the maintainer. As per the ticket guidelines, please don't set the Milestone field.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Summary: texlive-basic failed to installdb46 failed to install

Duplicate of #26939; please search before filing new tickets.

Note: See TracTickets for help on using tickets.