New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #26949 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

qt4-mac depends on itself

Reported by: MacPorts@… Owned by: michaelld@…
Priority: High Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: raimue@…
Port: qt4-mac

Description

There appears to be a circular dependency chain related to qbzr. The following excerpt seems to show the circular dependency chain.

$ sudo port -d install qbzr
<snip>
DEBUG: Didn't find receipt, going to depspec regex for: qt4-mac-devel
DEBUG: Searching for dependency: pkgconfig
DEBUG: Found Dependency: receipt exists for pkgconfig
DEBUG: Searching for dependency: qt4-mac
DEBUG: Didn't find receipt, going to depspec regex for: qt4-mac
DEBUG: Searching for dependency: zlib
DEBUG: Found Dependency: receipt exists for zlib
DEBUG: Searching for dependency: dbus
DEBUG: Found Dependency: receipt exists for dbus
DEBUG: Searching for dependency: openssl
DEBUG: Found Dependency: receipt exists for openssl
DEBUG: Searching for dependency: sqlite3
DEBUG: Found Dependency: receipt exists for sqlite3
DEBUG: Searching for dependency: tiff
DEBUG: Found Dependency: receipt exists for tiff
DEBUG: Searching for dependency: libpng
DEBUG: Found Dependency: receipt exists for libpng
DEBUG: Searching for dependency: libmng
DEBUG: Didn't find receipt, going to depspec regex for: libmng
DEBUG: Searching for dependency: jpeg
DEBUG: Found Dependency: receipt exists for jpeg
DEBUG: Checking for conflicts against qt4-mac
DEBUG: Searching for dependency: qt4-mac-devel
DEBUG: Didn't find receipt, going to depspec regex for: qt4-mac-devel
DEBUG: Searching for dependency: pkgconfig
DEBUG: Found Dependency: receipt exists for pkgconfig
DEBUG: Searching for dependency: qt4-mac
DEBUG: Didn't find receipt, going to depspec regex for: qt4-mac
DEBUG: Searching for dependency: zlib
DEBUG: Found Dependency: receipt exists for zlib
DEBUG: Searching for dependency: dbus
DEBUG: Found Dependency: receipt exists for dbus
DEBUG: Searching for dependency: openssl
DEBUG: Found Dependency: receipt exists for openssl
DEBUG: Searching for dependency: sqlite3
DEBUG: Found Dependency: receipt exists for sqlite3
DEBUG: Searching for dependency: tiff
DEBUG: Found Dependency: receipt exists for tiff
DEBUG: Searching for dependency: libpng
DEBUG: Found Dependency: receipt exists for libpng
DEBUG: Searching for dependency: libmng
DEBUG: Didn't find receipt, going to depspec regex for: libmng
DEBUG: Searching for dependency: jpeg
DEBUG: Found Dependency: receipt exists for jpeg
DEBUG: Checking for conflicts against qt4-mac
DEBUG: Searching for dependency: pkgconfig
DEBUG: Found Dependency: receipt exists for pkgconfig
DEBUG: Searching for dependency: qt4-mac
DEBUG: Didn't find receipt, going to depspec regex for: qt4-mac
DEBUG: too many nested evaluations (infinite loop?)
    while executing
"lshift args"
    (procedure "try" line 7)
    invoked from within
"try {
                    seek $fd $offset
                    gets $fd line
                    set name [lindex $line 0]
                    set len..."
    (procedure "mportlookup" line 23)
    invoked from within
"mportlookup $dep_portname"
Error: Internal error: port lookup failed: too many nested evaluations (infinite loop?)
Error: Status 1 encountered during processing.

I've attached a gzipped file containing the full debug output for the above command in case it is useful.

Attachments

qbzr.log.gz (8.0 KB) - added by MacPorts@… 4 years ago.
Full output of install with debug flag

Change History

Changed 4 years ago by MacPorts@…

Full output of install with debug flag

comment:1 follow-up: ↓ 2 Changed 4 years ago by ryandesign@…

  • Cc raimue@…, michaelld@… added
  • Summary changed from Error installing qbzr: to qbzr: too many nested evaluations (infinite loop?)

Perhaps a conflict with qt4-mac-devel? Do you have qt4-mac-devel installed? If so, deactivate or uninstall it, then you should be able to install qt4-mac.

comment:2 in reply to: ↑ 1 Changed 4 years ago by MacPorts@…

Replying to ryandesign@…:

Perhaps a conflict with qt4-mac-devel? Do you have qt4-mac-devel installed? If so, deactivate or uninstall it, then you should be able to install qt4-mac.

I don't have qt4-mac-devel installed. To be certain, I executed "port uninstall qt4-mac-devel" and re-tried "port install qbzr" with the same nested evaluations error result.

comment:3 Changed 4 years ago by michaelld@…

Do you have +universal set up somewhere as a default variant? If so, can you try without it?

comment:4 Changed 4 years ago by michaelld@…

OK; looks like the relevant lines of debug log are:

DEBUG: Searching for dependency: libmng
DEBUG: Didn't find receipt, going to depspec regex for: libmng
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/graphics/libmng
DEBUG: OS darwin/10.4.0 (Mac OS X 10.6) arch i386
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/muniversal-1.0.tcl
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Searching for dependency: jpeg
DEBUG: Found Dependency: receipt exists for jpeg
DEBUG: Checking for conflicts against qt4-mac
DEBUG: Searching for dependency: qt4-mac-devel
DEBUG: Didn't find receipt, going to depspec regex for: qt4-mac-devel
DEBUG: Searching for dependency: pkgconfig
DEBUG: Found Dependency: receipt exists for pkgconfig
DEBUG: Searching for dependency: qt4-mac
DEBUG: Didn't find receipt, going to depspec regex for: qt4-mac
DEBUG: Searching for dependency: zlib
DEBUG: Found Dependency: receipt exists for zlib
DEBUG: Searching for dependency: dbus
DEBUG: Found Dependency: receipt exists for dbus
DEBUG: Searching for dependency: openssl
DEBUG: Found Dependency: receipt exists for openssl
DEBUG: Searching for dependency: sqlite3
DEBUG: Found Dependency: receipt exists for sqlite3
DEBUG: Searching for dependency: tiff
DEBUG: Found Dependency: receipt exists for tiff
DEBUG: Searching for dependency: libpng
DEBUG: Found Dependency: receipt exists for libpng
DEBUG: Searching for dependency: libmng
DEBUG: Didn't find receipt, going to depspec regex for: libmng

This looks like an infinite loop being caused by checking for "conflicts against"; maybe? And, yes, it looks like muniversal is coming into play. Can you try building libmng without +universal & then trying qbzr again?

comment:5 Changed 4 years ago by jmr@…

  • Cc michaelld@… removed
  • Owner changed from macports-tickets@… to michaelld@…
  • Port changed from qbzr to qt4-mac
  • Summary changed from qbzr: too many nested evaluations (infinite loop?) to qt4-mac depends on itself

Actually it's quite simple:

% port deps qt4-mac
Full Name: qt4-mac @4.7.0_0+quartz
Build Dependencies:   pkgconfig
Library Dependencies: qt4-mac, zlib, dbus, openssl, sqlite3, tiff, libpng,
                      libmng, jpeg

comment:6 follow-up: ↓ 7 Changed 4 years ago by michaelld@…

Do a "clean" then "selfupdate" and then try again. I just removed a cyclic dependency from qt4-mac in r72678. Maybe that will help?

comment:7 in reply to: ↑ 6 Changed 4 years ago by MacPorts@…

Replying to michaelld@…:

Do a "clean" then "selfupdate" and then try again. I just removed a cyclic dependency from qt4-mac in r72678. Maybe that will help?

Yes, that fixed the error! Thank you!

comment:8 Changed 4 years ago by macsforever2000@…

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.