Opened 10 years ago

Closed 10 years ago

#27057 closed defect (fixed)

Doxygen 1.7.2 not building with +wizard

Reported by: dreadrik@… Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: doxygen wizard Cc: michaelld (Michael Dickens)
Port: doxygen

Description (last modified by ryandesign (Ryan Schmidt))

This is on Mac OS X 10.6.4 with qt4-mac @4.7.0_0+quartz installed.

Relevant log part:

:msg:patch --->  Applying patches to doxygen
:info:patch --->  Applying /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/doxygen/files/patch-Makfile.in.diff
:debug:patch Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_doxygen/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:patch Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_doxygen/work/doxygen-1.7.2" && /usr/bin/patch -p0'
:info:patch patching file addon/doxywizard/Makefile.in
:debug:patch Executing proc-post-org.macports.patch-patch-0
:debug:patch Executing proc-post-org.macports.patch-patch-1
:error:patch Target org.macports.patch returned: can't read "qt_dir": no such variable
:debug:patch Backtrace: can't read "qt_dir": no such variable while executing "$post $targetname"
:info:patch Warning: the following items did not execute (for doxygen): org.macports.destroot org.macports.patch org.macports.configure org.macports.build

Change History (4)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: michaelld@… added; css@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to css@…

comment:2 Changed 10 years ago by cssdev

Was something not done properly in r72591? I don't know the circumstances around that change.

comment:3 Changed 10 years ago by michaelld (Michael Dickens)

The issue is in the way the Qt4 portgroup is included; so, yes, it's about r72591 sort of. I'm working on it & will check in a patch shortly.

comment:4 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

OK; should be fixed in r72875. Please do:

sudo port clean doxygen
sudo port selfupdate
sudo port install doxygen +wizard [+other_variants]

and see if it works for you. I'm closing this ticket as fixed, but please do reopen if the issue of this ticket is not resolved for you.

Note: See TracTickets for help on using tickets.