Opened 10 years ago

Closed 10 years ago

#27124 closed defect (invalid)

error when installing squid

Reported by: deanna1ynne@… Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: squid

Description (last modified by jmroot (Joshua Root))

I tried installing squid with macports, and am getting an error that I have no idea how to resolve. I'm not very computer savvy, but I need squid to work on my computer so that I can install dansguardian.

Here's what I get when I put "sudo port install squid" into the terminal:

--->  Computing dependencies for squid
--->  Dependencies to be installed: openssl
--->  Fetching openssl
--->  Attempting to fetch openssl-1.0.0a.tar.gz from http://distfiles.macports.org/openssl
--->  Verifying checksum(s) for openssl
--->  Extracting openssl
--->  Applying patches to openssl
--->  Configuring openssl
--->  Building openssl
--->  Staging openssl into destroot
--->  Installing openssl @1.0.0a_1
--->  Activating openssl @1.0.0a_1
--->  Cleaning openssl
--->  Fetching squid
--->  Attempting to fetch squid-2.7.STABLE9.tar.bz2 from http://mirrors.24-7-solutions.net/pub/squid/
--->  Attempting to fetch squid-2.7.STABLE9.tar.bz2 from http://www.squid-cache.org/Versions/v2/2.7/
--->  Verifying checksum(s) for squid
--->  Extracting squid
--->  Applying patches to squid
--->  Configuring squid
Error: Target org.macports.configure returned: configure failure: shell command failed
Log for squid is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_squid/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Please help me! I've tried installing squid manually and using webmin, and kept getting errors when trying to initialize the cache. I don't know if this is related to that problem or now.

Thank you very much.

Change History (2)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to jmr@…
Port: squid added
Status: newassigned

Please remember to preview and use WikiFormatting, fill in the Port field, and cc the maintainer. Attach the main.log mentioned in the output.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: assignedclosed

Closing since there's no log; feel free to reopen if you can provide it.

Note: See TracTickets for help on using tickets.