Opened 10 years ago

Closed 10 years ago

#27177 closed defect (duplicate)

dsniff fail to install

Reported by: ajcblyth@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: dsniff

Description (last modified by jmroot (Joshua Root))

sh-3.2# port install -d dsniff
--->  Computing dependencies for dsniff
--->  Building dsniff
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsniff/work/dsniff-2.3" && /usr/bin/make -j2 all " returned error 2
Command output: ranlib libmissing.a
ranlib: file: libmissing.a(dummy.o) has no symbols
/usr/bin/gcc-4.2 -O2 -DBIND_8_COMPAT -arch x86_64 -D_BSD_SOURCE -DHAVE_SOCKADDR_SA_LEN -DLIBNET_BSDISH_OS -DLIBNET_BSD_BYTE_SWAP -DDSNIFF_LIBDIR=\"/opt/local/lib/\" -I. -I/opt/local/include -I/opt/local/include -I/opt/local/include  -I/opt/local/include -I/opt/local/include -I./missing -c ./arp.c
./arpspoof.c:25: warning: 'struct ether_addr' declared inside parameter list
./arpspoof.c:25: warning: its scope is only this definition or declaration, which is probably not what you want
./arpspoof.c:26: warning: 'struct ether_addr' declared inside parameter list
./arpspoof.c: In function 'arp_send':
./arpspoof.c:49: warning: passing argument 1 of 'libnet_get_hwaddr' from incompatible pointer type
./arpspoof.c:49: error: too many arguments to function 'libnet_get_hwaddr'
./arpspoof.c:60: warning: passing argument 6 of 'libnet_build_ethernet' from incompatible pointer type
./arpspoof.c:60: error: too few arguments to function 'libnet_build_ethernet'
./arpspoof.c:64: error: 'ETH_H' undeclared (first use in this function)
./arpspoof.c:64: error: (Each undeclared identifier is reported only once
./arpspoof.c:64: error: for each function it appears in.)
./arpspoof.c:64: error: too few arguments to function 'libnet_build_arp'
./arpspoof.c:67: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
./arpspoof.c:71: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
./arpspoof.c:73: warning: format '%s' expects type 'char *', but argument 4 has type 'int'
./arpspoof.c:73: warning: format '%s' expects type 'char *', but argument 5 has type 'int'
./arpspoof.c:77: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
./arpspoof.c:78: warning: format '%s' expects type 'char *', but argument 4 has type 'int'
./arpspoof.c:80: warning: passing argument 1 of 'ether_ntoa' from incompatible pointer type
./arpspoof.c: In function 'arp_find':
./arpspoof.c:114: warning: passing argument 2 of 'arp_cache_lookup' from incompatible pointer type
./arpspoof.c: In function 'main':
./arpspoof.c:181: warning: assignment makes pointer from integer without a cast
make: *** [arpspoof.o] Error 1
make: *** Waiting for unfinished jobs....
./arp.c: In function 'arp_cache_lookup':
./arp.c:74: warning: incompatible implicit declaration of built-in function 'memcpy'

Error: Status 1 encountered during processing.
Before reporting a bug, first run the command again with the -d flag to get complete output.
sh-3.2# 

Change History (3)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Port: dsniff added

Please remember to preview and use WikiFormatting, and to fill in the Port field.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Version: 1.9.11.8.2

You don't appear to actually be running 1.9.1 BTW. I don't know if it will resolve this particular problem, but you should really selfupdate in any case.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #23971; please search before filing new tickets.

Note: See TracTickets for help on using tickets.