Opened 10 years ago

Closed 10 years ago

#27192 closed defect (duplicate)

openjdk6 @b16 +install failure due to missing classes in package com.sun.corba.se.internal.io

Reported by: nhojpatrick (John Patrick) Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: bgrupe27
Port: openjdk6

Description (last modified by jmroot (Joshua Root))

I've just tried installing openjdk6, because apple have announced that they have deprecated their implementation of java.

It looks as simple as a dependency has been removed or added for classes in the package com.sun.corba.se.internal.io.

$ sudo port install openjdk6
Password:
--->  Computing dependencies for openjdk6
--->  Building openjdk6
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for openjdk6 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The log is attached but contains:

$ cat /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/main.log
[...]
:info:build # Running javah:
:info:build /opt/local/share/java/openjdk6_bootstrap/bin/java  -client -Xmx896m -Xms128m -XX:PermSize=32m -XX:MaxPermSize=160m "-Xbootclasspath/p:/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/build/bsd-i586/langtools/dist/bootstrap/lib/javah.jar:/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/build/bsd-i586/langtools/dist/bootstrap/lib/javadoc.jar:/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/build/bsd-i586/langtools/dist/bootstrap/lib/javac.jar" -jar /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/build/bsd-i586/langtools/dist/bootstrap/lib/javah.jar -bootclasspath /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/build/bsd-i586/corba/classes -d /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/build/bsd-i586/corba/tmp/sun/com.sun.corba.se.internal.io/ioser12/CClassHeaders/ \
:info:build 		com.sun.corba.se.internal.io.IIOPInputStream com.sun.corba.se.internal.io.IIOPOutputStream com.sun.corba.se.internal.io.ObjectStreamClass com.sun.corba.se.internal.io.LibraryManager   
:info:build error: cannot access com.sun.corba.se.internal.io.IIOPInputStream
:info:build class file for com.sun.corba.se.internal.io.IIOPInputStream not found
:info:build javadoc: error - Class com.sun.corba.se.internal.io.IIOPInputStream not found.
:info:build error: cannot access com.sun.corba.se.internal.io.IIOPOutputStream
:info:build class file for com.sun.corba.se.internal.io.IIOPOutputStream not found
:info:build javadoc: error - Class com.sun.corba.se.internal.io.IIOPOutputStream not found.
:info:build error: cannot access com.sun.corba.se.internal.io.ObjectStreamClass
:info:build class file for com.sun.corba.se.internal.io.ObjectStreamClass not found
:info:build javadoc: error - Class com.sun.corba.se.internal.io.ObjectStreamClass not found.
:info:build error: cannot access com.sun.corba.se.internal.io.LibraryManager
:info:build class file for com.sun.corba.se.internal.io.LibraryManager not found
:info:build javadoc: error - Class com.sun.corba.se.internal.io.LibraryManager not found.
:info:build Error: No classes were specified on the command line.  Try -help.
:info:build make[4]: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/build/bsd-i586/corba/tmp/sun/com.sun.corba.se.internal.io/ioser12/obj/.class.headers.i586] Error 15
:info:build make[3]: *** [build] Error 1
:info:build make[2]: *** [build] Error 1
:info:build make[1]: *** [build] Error 1
:info:build make: *** [corba-build] Error 2
:info:build make: *** Waiting for unfinished jobs....
:info:build 
:info:build BUILD SUCCESSFUL
:info:build Total time: 7 seconds
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/work/./" && /usr/bin/make -j2 all ALT_BOOTDIR="/opt/local/share/java/openjdk6_bootstrap" ALT_BINARY_PLUGS_PATH="/opt/local/share/java/icedtea6-plugs/jre/lib/rt-closed.jar" ANT_HOME="/opt/local/share/java/apache-ant" ALT_FREETYPE_HEADERS_PATH="/opt/local/include" ALT_FREETYPE_LIB_PATH="/opt/local/lib" ALT_CUPS_HEADERS_PATH="/usr/include" ALT_MOTIF_DIR="/opt/local" ALT_X11_PATH="/opt/local" ALT_DEVTOOLS_PATH=/usr ALT_CACERTS_FILE=/System/Library/Frameworks/JavaVM.framework/Home/lib/security/cacerts NO_DOCS=true HOTSPOT_BUILD_JOBS=2 " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for openjdk6): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for openjdk6 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_java_openjdk6/main.log
$ 

I've got the latest version of java from apple.

$ java -version
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)
$

Attachments (1)

main.log (110.4 KB) - added by nhojpatrick (John Patrick) 10 years ago.
install log file

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by nhojpatrick (John Patrick)

Attachment: main.log added

install log file

comment:1 Changed 10 years ago by bgrupe27

Just out of curiousity: Does it build when you've got the development package from Apple installed?

comment:2 Changed 10 years ago by nhojpatrick (John Patrick)

What development package are you referring too?

I do have XCode installed, and also the Apple JDK.

If your give me instructions for download, I'll try again.

comment:3 Changed 10 years ago by bgrupe27

It can be found here:

http://connect.apple.com/cgi-bin/WebObjects/MemberSite.woa/wa/download?path=%2FJava%2Fjava_for_mac_os_x_10.6_update_3_developer_package%2Fjavadeveloper_10.6_10m3261.dmg

Please also note that the OpenJDK for macports is way outdated and may not compile at all on Snow Leopard.

comment:4 Changed 10 years ago by bgrupe27

Cc: bgrupe@… added

Cc Me!

comment:5 Changed 10 years ago by nhojpatrick (John Patrick)

Just download "Java for Mac OS X 10.6 Update 3 Developer Package" and it has the same build error as before.

I also did a uninstall openjdk6 openjdk6_bootstrap before re-installing.

comment:6 Changed 10 years ago by bgrupe27

Then I'd think the best bet would be to upgrade the macports OpenJDK port.

I don't know however, how much love OpenJDK received for OSX lately. Judging from the existance of a bootstrapping port this will be a non-trivial upgrade...

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to landonf@…
Priority: HighNormal

Please remember to preview and use WikiFormatting, and to cc the maintainer. As per the ticket guidelines, the High priority is reserved for the use of MacPorts team members.

comment:8 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #20956.

Note: See TracTickets for help on using tickets.