Opened 10 years ago

Closed 9 years ago

#27302 closed defect (fixed)

curl-ca-bundle: checksum mismatch

Reported by: jj@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: easye, eric@…, jacqueminv@…, macports@…, moussor@…
Port: curl-ca-bundle

Description (last modified by ryandesign (Ryan Schmidt))

I search the issues database and this is a similar issue to what was reported in March 2010. I apologize if this has already been addressed.

DEBUG: Starting logging for curl-ca-bundle
DEBUG: Executing org.macports.main (curl-ca-bundle)
DEBUG: Skipping completed org.macports.fetch (curl-ca-bundle)
--->  Verifying checksum(s) for curl-ca-bundle
DEBUG: checksum phase started at Sat Nov 13 11:02:32 EST 2010
DEBUG: Executing org.macports.checksum (curl-ca-bundle)
--->  Checksumming curl-7.21.2.tar.bz2
DEBUG: Correct (sha1) checksum for curl-7.21.2.tar.bz2
DEBUG: Correct (rmd160) checksum for curl-7.21.2.tar.bz2
--->  Checksumming certdata-1.65.txt
Error: Checksum (md5) mismatch for certdata-1.65.txt
Portfile checksum: certdata-1.65.txt md5 b93bd8dd813e4b0c12ddcc44dbfe1dbf
Distfile checksum: certdata-1.65.txt md5 bf95fa255ab4ac734f454369a303141d
Error: Checksum (sha1) mismatch for certdata-1.65.txt
Portfile checksum: certdata-1.65.txt sha1 774c0132ac6920a4f37ce670bed4abcb6e21476c
Distfile checksum: certdata-1.65.txt sha1 0ca2a470922249ec6877473e03eaad293b4cfb45
Error: Checksum (rmd160) mismatch for certdata-1.65.txt
Portfile checksum: certdata-1.65.txt rmd160 5af26ece6f3e379b247ac8da565d41ff36768972
Distfile checksum: certdata-1.65.txt rmd160 baddb9c10101cbf38ebe05ecc5ab3739f98595fd
The correct checksum line may be:
checksums           curl-7.21.2.tar.bz2 \
                    md5     ca96df88e044c7c25d19692ec8b250b2 \
                    sha1    f729552a905033dbd0d2cf56e40c7048f2d8331e \
                    rmd160  fcb1302f79741bc3e488fcee1206284f4cb9e6ca \
                    certdata-1.65.txt \
                    md5     bf95fa255ab4ac734f454369a303141d \
                    sha1    0ca2a470922249ec6877473e03eaad293b4cfb45 \
                    rmd160  baddb9c10101cbf38ebe05ecc5ab3739f98595fd
Error: Target org.macports.checksum returned: Unable to verify file checksums
DEBUG: Backtrace: Unable to verify file checksums
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for curl-ca-bundle): org.macports.activate org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Failed to install curl-ca-bundle
Log for curl-ca-bundle is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_curl-ca-bundle/main.log
Error: The following dependencies were not installed: curl curl-ca-bundle openssl zlib pkgconfig gawk gd2 autoconf help2man p5-locale-gettext m4 automake fontconfig freetype jpeg libpng libtool xpm xorg-libXext xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python26 bzip2 db46 gdbm readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice radlib
Error: Status 1 encountered during processing.

Change History (18)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: easieste@… eric@… cjflory@… added
Description: modified (diff)
Keywords: curl checksum error certdata-1.65.txt removed
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: Error: Checksum (md5) mismatch for certdata-1.65.txtcurl-ca-bundle: checksum mismatch

I search the issues database and this is a similar issue to what was reported in March 2010.

Yes, this issue will recur every time they update the certdata.txt file. I will update the port.

Has duplicate #27303.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Fixed in r73458.

comment:3 Changed 10 years ago by jacqueminv@…

Cc: jacqueminv@… added

Cc Me!

comment:4 Changed 10 years ago by jacqueminv@…

Resolution: fixed
Status: closedreopened

I still get the checksum failure on my side. Do I miss something?

comment:5 Changed 10 years ago by easye

Obvious question: did you remove the checksum file from the distfiles directory so it gets downloaded again?

  osx$ sudo port clean --dist curl-ca-bundle

should do it.

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

jacqueminv, you need to sync or selfupdate to receive my changes, then try again.

sudo port selfupdate

easieste, cleaning is not necessary, because the filename changes when I update the port. The checksum error was reported for "certdata-1.65.txt" but after my update the filename is now "certdata-1.66.txt".

comment:7 Changed 10 years ago by jacqueminv@…

the selfupdate didn't solve my issue, the clean did.

thank you.

comment:8 Changed 10 years ago by macports@…

None of this (clean; selfupdate) nor uninstalling and reinstalling curl-ca-bundle has helped. I get this:

$ sudo port install git-core
--->  Computing dependencies for openssl
--->  Fetching openssl
--->  Attempting to fetch openssl-1.0.0b.tar.gz from http://distfiles.macports.org/openssl
--->  Verifying checksum(s) for openssl
--->  Extracting openssl
--->  Applying patches to openssl
--->  Configuring openssl
--->  Building openssl
--->  Staging openssl into destroot
--->  Computing dependencies for openssl
--->  Installing openssl @1.0.0b_0
--->  Deactivating openssl @1.0.0a_1
--->  Cleaning openssl
--->  Activating openssl @1.0.0b_0
--->  Cleaning openssl
--->  Computing dependencies for git-core
--->  Dependencies to be installed: curl curl-ca-bundle
--->  Verifying checksum(s) for curl-ca-bundle
Error: Checksum (sha1) mismatch for certdata-1.66.txt
Error: Checksum (rmd160) mismatch for certdata-1.66.txt
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Failed to install curl-ca-bundle
Log for curl-ca-bundle is at: <snip>
Error: The following dependencies were not installed: curl curl-ca-bundle
Error: Status 1 encountered during processing.

On top of this not working, it stops upgrade outdated from working. Seems to me it should continue after a failure.

comment:9 Changed 10 years ago by ryandesign (Ryan Schmidt)

curl-ca-bundle has been updated again. I need to update the portfile again.

MacPorts does not proceed after a failure. If you want that, use the -p option.

comment:10 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Updated in r73578.

comment:11 Changed 10 years ago by cjflory@…

Cc: cjflory@… removed

Cc Me!

comment:12 Changed 10 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:13 in reply to:  12 Changed 10 years ago by jj@…

Resolution: fixed
Status: closedreopened

Replying to macports@…:

Cc Me!

I am new to macports so not sure what the procedure is here on continuing errors after the issue is closed. When I run "sudo port install wview" I still get the cert error.

-->  Computing dependencies for wview
--->  Dependencies to be installed: curl curl-ca-bundle openssl zlib pkgconfig gawk gd2 autoconf help2man p5-locale-gettext m4 automake fontconfig freetype jpeg libpng libtool xpm xorg-libXext xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python26 bzip2 db46 gdbm readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice radlib
--->  Verifying checksum(s) for curl-ca-bundle
Error: Checksum (md5) mismatch for certdata-1.65.txt
Error: Checksum (sha1) mismatch for certdata-1.65.txt
Error: Checksum (rmd160) mismatch for certdata-1.65.txt
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Failed to install curl-ca-bundle
Log for curl-ca-bundle is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_curl-ca-bundle/main.log
Error: The following dependencies were not installed: curl curl-ca-bundle openssl zlib pkgconfig gawk gd2 autoconf help2man p5-locale-gettext m4 automake fontconfig freetype jpeg libpng libtool xpm xorg-libXext xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python26 bzip2 db46 gdbm readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice radlib
Error: Status 1 encountered during processing.

Thanks for you advice!

comment:14 Changed 10 years ago by jj@…

Sorry I missed this from your earlier email. I ran the following command and then re-ran the port install wview again and it was successful. sudo port selfupdate Thanks again.

comment:15 Changed 10 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: reopenedclosed

comment:16 Changed 9 years ago by moussor@…

Resolution: fixed
Status: closedreopened

The problem has reappeared with certdata-1.71.txt. Here is the transcript:

--->  Verifying checksum(s) for curl-ca-bundle
Error: Checksum (sha1) mismatch for certdata-1.71.txt
Error: Checksum (rmd160) mismatch for certdata-1.71.txt
Error: Target org.macports.checksum returned: Unable to verify file checksums

comment:17 Changed 9 years ago by moussor@…

Cc: moussor@… added

Cc Me!

comment:18 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Please don't re-open 4-month-old fixed issues. This new issue was filed as #28982 and fixed.

Note: See TracTickets for help on using tickets.