Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#27333 closed enhancement (fixed)

[bacula @5.0.3] missing tcp-wrappers support

Reported by: martinezino@… Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: bacula

Description

Dear MacPorts-Team,

i want to request kindly tcp-wrappers support in the bacula port.

--- bacula.Portfile 2010-11-15 22:30:58.000000000 +0100
+++ bacula.Portfile 2010-11-15 22:30:43.000000000 +0100
@@ -57,6 +57,7 @@
                  --disable-gnome \
                  --disable-wx-console \
                  --disable-tray-monitor \
+                 --with-tcp-wrappers \
                  ac_cv_lib_ssl_EVP_PKEY_encrypt_old=yes
 
 # The ac_cv_lib_ssl_EVP_PKEY_encrypt_old=yes line above is for openssl 1.0

This compiles fine (at least on my system 10.5):

$ otool -L /opt/local/sbin/bacula-fd 
/opt/local/sbin/bacula-fd:
	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 476.19.0)
	/opt/local/lib/libbacfind-5.0.3.dylib (compatibility version 0.0.0, current version 0.0.0)
	/opt/local/lib/libbacpy-5.0.3.dylib (compatibility version 0.0.0, current version 0.0.0)
	/opt/local/lib/libbaccfg-5.0.3.dylib (compatibility version 0.0.0, current version 0.0.0)
	/opt/local/lib/libbac-5.0.3.dylib (compatibility version 0.0.0, current version 0.0.0)
	/opt/local/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.5)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.5)
	/usr/lib/libwrap.7.dylib (compatibility version 7.0.0, current version 7.6.0)
	/opt/local/lib/libintl.8.dylib (compatibility version 10.0.0, current version 10.1.0)
	/opt/local/lib/libiconv.2.dylib (compatibility version 8.0.0, current version 8.0.0)
	/opt/local/lib/libssl.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/opt/local/lib/libcrypto.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)

Best wishes,

PM

Change History (3)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Keywords: bacula sysutils removed
Owner: changed from macports-tickets@… to macsforever2000@…
Port: @5.0.3 removed
Status: newassigned
Type: requestenhancement
Version: 1.9.2

comment:2 Changed 9 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: assignedclosed

comment:3 Changed 9 years ago by martinezino@…

Thank you!

Note: See TracTickets for help on using tickets.