Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#27349 closed update (fixed)

kipi-plugins: updated portfile to 1.6.0

Reported by: jgosmann (Jan Gosmann) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc: julien@…, CBraun@…, feurer.matthias@…, nospam420@…
Port: kipi-plugins

Description

Finally I was able to update the outdated kipi-plugins port. I will attach a patch for the portfile.

Attachments (4)

disable-gtk-dependencies-CMakeLists.txt.diff.diff (679 bytes) - added by jgosmann (Jan Gosmann) 10 years ago.
Patch to apply to the patchfile disable-gtk-dependencies-CMakeLists.txt.diff
kipi-plugins-1.5.0.diff (3.3 KB) - added by ryandesign (Ryan Schmidt) 10 years ago.
combined patch
Portfile-kipi-plugins.diff (2.0 KB) - added by jgosmann (Jan Gosmann) 10 years ago.
Patch to apply to the portfile
disable-gtk-dependencies-CMakeLists.txt.diff (1.0 KB) - added by jgosmann (Jan Gosmann) 10 years ago.
Patchfile referenced by the portfile for version 1.6.0

Download all attachments as: .zip

Change History (16)

Changed 10 years ago by jgosmann (Jan Gosmann)

Patch to apply to the patchfile disable-gtk-dependencies-CMakeLists.txt.diff

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Keywords: haspatch maintainer added; digikam removed
Version: 1.9.2

comment:2 Changed 10 years ago by julien@…

Cc: julien@… added

Cc Me!

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

Your patch did not apply cleanly. Your patch is for an update from kipi-plugins 1.2.0 to 1.5.0 but the version currently in MacPorts is 1.1.0.

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Ah, you want us to resolve #25076 first.

Changed 10 years ago by ryandesign (Ryan Schmidt)

Attachment: kipi-plugins-1.5.0.diff added

combined patch

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

I've attached a new patch based on the current version of the port that is in the repository, incorporating all the changes from #25076. I cannot test it however because I cannot get dependency kdegraphics4 to build; see #27406.

Changed 10 years ago by jgosmann (Jan Gosmann)

Attachment: Portfile-kipi-plugins.diff added

Patch to apply to the portfile

Changed 10 years ago by jgosmann (Jan Gosmann)

Patchfile referenced by the portfile for version 1.6.0

comment:6 Changed 10 years ago by jgosmann (Jan Gosmann)

I've attached an updated portfile (and an associated patchfile) for the new version 1.6.0 released today. This time the diff should be against the version in the repository.

comment:7 Changed 10 years ago by CBraun@…

How can i apply the patch? Where can i find the original file which i wan`t to patch?

thanks

comment:8 Changed 10 years ago by CBraun@…

Cc: CBraun@… added

Cc Me!

comment:9 Changed 10 years ago by feurer.matthias@…

Cc: feurer.matthias@… added

Cc Me!

comment:10 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed
Summary: kipi-plugins @1.5.0 updated portfilekipi-plugins: updated portfile to 1.6.0

comment:11 Changed 10 years ago by nospam420@…

I am having problems installing digikam even with kipi-plugins 1.6.0. See comment:ticket:27178:25

comment:12 Changed 10 years ago by nospam420@…

Cc: nospam420@… added

Cc Me!

Note: See TracTickets for help on using tickets.