Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#27362 closed defect (worksforme)

XChat2 2.8.8 build error

Reported by: ekagaurangadas@… Owned by: afb@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: xchat2

Description

When trying to build xchat2 2.8.8 I get an error attached

Attachments (2)

main.log (74.4 KB) - added by ekagaurangadas@… 9 years ago.
main.2.log (74.4 KB) - added by ekagaurangadas@… 9 years ago.

Download all attachments as: .zip

Change History (19)

Changed 9 years ago by ekagaurangadas@…

Attachment: main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to afb@…
Port: xchat2 added

comment:2 Changed 9 years ago by afb@…

Resolution: fixed
Status: newclosed

So don't build it with +universal ?

Disabled, r73554.

comment:3 Changed 9 years ago by ekagaurangadas@…

Resolution: fixed
Status: closedreopened

Still not.

Changed 9 years ago by ekagaurangadas@…

Attachment: main.2.log added

comment:4 Changed 9 years ago by afb@…

You'll need to clean first, too.

comment:5 Changed 9 years ago by ekagaurangadas@…

I did: sudo port -v clean xchat2 and still the same... should be clean all?

comment:6 Changed 9 years ago by ekagaurangadas@…

same with sudo port -v clean --all xchat2

comment:7 Changed 9 years ago by jmroot (Joshua Root)

I guess your perl is universal?

comment:8 Changed 9 years ago by ekagaurangadas@…

Dunno, I never decided it to be, so how can I fix that?

comment:9 Changed 9 years ago by afb@…

Resolution: worksforme
Status: reopenedclosed

I'd go with port install xchat2 -universal

comment:10 Changed 9 years ago by ekagaurangadas@…

same, did clean before running it.

I see the same error over and over

gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags

doesn't that gives you a hint? or is unrelated?

comment:11 Changed 9 years ago by afb@…

multiple -arch flags = universal

xchat2 should build OK when not using +universal no idea what makes it use +universal in your case. can reopen the bug if you like, but cannot reproduce...

comment:12 Changed 9 years ago by jmroot (Joshua Root)

What I meant to imply in my previous comment is that the multiple -arch flags are coming from perl.

comment:13 Changed 9 years ago by ekagaurangadas@…

So I should recompile perl with -universal?

comment:14 in reply to:  12 Changed 9 years ago by afb@…

ah, in the $PERL_CFLAGS you mean. Yeah, that would make sense - if perl was built universal.

/opt/local/bin/perl -MExtUtils::Embed -e ccopts

comment:15 Changed 9 years ago by ekagaurangadas@…

eka@gauri:~ $ /opt/local/bin/perl -MExtUtils::Embed -e ccopts

-O2 -arch x86_64 -arch i386 -fno-common -DPERL_DARWIN -I/opt/local/include -no-cpp-precomp -fno-strict-aliasing -pipe -I/opt/local/include -I/opt/local/lib/perl5/5.8.9/darwin-2level/CORE

What does that mean?

comment:16 in reply to:  15 Changed 9 years ago by afb@…

Replying to ekagaurangadas@…:

What does that mean?

It means your perl was built +universal (it has more than one -arch flag in there)

Now allowed too, r73567.

comment:17 Changed 9 years ago by ekagaurangadas@…

That did it. Thanks!

Note: See TracTickets for help on using tickets.