Opened 10 years ago

Closed 10 years ago

#27667 closed defect (fixed)

php5-iconv: can't read "php5extension.extension_dir"

Reported by: sven.kauber@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: php5-iconv

Description (last modified by ryandesign (Ryan Schmidt))

First updated ports tree, then did sudo port upgrade outdated. All went fine until the first php5 add-on module:

--->  Computing dependencies for php5-iconv
--->  Configuring php5-iconv
Error: Target org.macports.configure returned: can't read "php5extension.extension_dir": /opt/local/lib/php/extensions/no-debug-non-zts-20090626
Log for php5-iconv is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_php_php5-iconv/main.log

The given directory (/opt/local/lib/php/extensions/no-debug-non-zts-20090626) does exist and even has world-writable rights.

Attachments (1)

main.log (22.3 KB) - added by sven.kauber@… 10 years ago.
main.log

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:2 in reply to:  description Changed 10 years ago by ryandesign (Ryan Schmidt)

Port: php5-iconv added
Summary: Unable to upgrade or install php5 addon modulesphp5-iconv: can't read "php5extension.extension_dir"

Replying to sven.kauber@…:

Error: Target org.macports.configure returned: can't read "php5extension.extension_dir": /opt/local/lib/php/extensions/no-debug-non-zts-20090626

Curious. In my experience the error "can't read" refers to an inability to access a MacPorts variable (the php5extension.extension_dir variable in this case), though its value seems to be printed right after it? What happens if you run this command yourself:

/opt/local/bin/php-config --extension-dir

Do you get the same error installing any other php5 module port?

What version and variants of php5 are installed?

comment:3 Changed 10 years ago by sven.kauber@…

When I run that command, I'll get /opt/local/lib/php/extensions/no-debug-non-zts-20090626 . I have updated PHP to 5.3.4. port installed php5 shows this response:

php5 @5.3.4_0+apache2 (active)

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

That looks normal. Try cleaning the port, then trying again:

sudo port clean php5-iconv
sudo port install php5-iconv

If that fails again, please attach the full main.log file and I'll compare it with mine.

Changed 10 years ago by sven.kauber@…

Attachment: main.log added

main.log

comment:5 in reply to:  4 Changed 10 years ago by sven.kauber@…

I attached the main.log. cleaning and re-installing did not help.

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

That's not a clean log (it has lines containing "Skipping completed"); clean and try again, and attach the complete new main.log.

The interesting error in the log so far is

2010-12-15 21:18:56.003 gsed[63124:10b] _CFGetHostUUIDString: unable to determine UUID for host. Error: 35

What kind of Mac are you using? Running a Google search for "_CFGetHostUUIDString: unable to determine UUID for host", I only see posts from people who aren't actually using real Macs.

comment:7 Changed 10 years ago by sven.kauber@…

I had indeed just a test environment - just have glimpse of how Mac and Linux or FreeBSD would differ in server use, how things are configured, etc. Thanks for thinking with me this far. I think this ticket is not valid as the systems are not comparable.

comment:8 Changed 10 years ago by ryandesign (Ryan Schmidt)

Ok, I'm able to reproduce the problem if I edit my php-config script and force it to print something to stderr in addition, and I fixed the php5-extension portgroup in r74413 to no longer care about stderr output from php-config. Let me know if that helps?

comment:9 Changed 10 years ago by sven.kauber@…

Yes, that did help. Thank you!

comment:10 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.